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Welcome to STEP 7...

...the SIMATIC standard software for creating programmable logic control
programs in Ladder Logic, Function Block Diagram, or Statement List for SIMATIC
S7-300/400 stations.

About This Getting Started Manual

In this manual, you will get to know the basics of SIMATIC STEP 7. We will show
you the most important screen dialog boxes and the procedures to follow using
practical exercises, which are structured so that you can start with almost any
chapter.

Each section is split into two parts: a descriptive part, marked in gray, and a
process-oriented part, marked in green. The instructions start with an arrow in the
green margin and may be spread out over several pages, finishing in a full stop
and a box containing related topics.

Previous experience of working with the mouse, window handling, pull-down
menus, etc. would be useful, and you should preferably be familiar with the basic
principles of programmable logic control.

The STEP 7 training courses provide you with in-depth knowledge above and
beyond the contents of this Getting Started manual, teaching you how entire
automation solutions can be created with STEP 7.

Requirements for Working with the Getting Started Manual

In order to carry out the practical exercises for STEP 7 in this Getting Started
manual, you require the following:

• A Siemens programming device or a PC

• The STEP 7 software package and the authorization diskette

• A SIMATIC S7-300 or S7-400 programmable controller
(for Chapter 7 "Downloading and Debugging the Program").

Additional Documentation on STEP 7

• STEP 7 Basic Information

• STEP 7 Reference Information

After you have installed STEP 7, you will find the electronic manuals in the Start
menu under Simatic > Documentation or alternatively, you can order them from
any Siemens sales center. All of the information in the manuals can be called up
in STEP 7 from the online help.

Have fun and good luck!

SIEMENS AG
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1 Introduction to STEP 7

1.1 What You Will Learn

Using practical exercises, we will show you how easy it is to program in Ladder
Logic, Statement List, or Function Block Diagram with STEP 7.

Detailed instructions in the individual chapters will show you step-by-step the
many ways in which you can use STEP 7.

Creating a Program with Binary Logic

In Chapters 2 to 7, you will create a program with binary logic. Using the
programmed logic operations, you will address the inputs and outputs of your CPU
(if present).

The programming examples in the Getting Started manual are based, among other
things, on three fundamental binary logic operations.

The first binary logic operation, which you will program later on, is the AND
function. The AND function can be best illustrated in a circuit diagram using two
keys.

The second binary logic operation is the OR function. The OR function can also be
represented in a circuit diagram.

Key 1 Key 2

Key 3

If both Key 1 and Key 2
are pressed, the bulb
lights up.

Key 4
If either key 3 or key 4
is pressed, the bulb
lights up.
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The third binary logic operation is the memory element. The SR function reacts
within a circuit diagram to certain voltage states and passes these on accordingly.

Memory Element

S

R

Key S

Key R

If key S is pressed, the bulb lights up
and remains lit until key R is pressed.
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1.2 Combining Hardware and Software

Using the STEP 7 software, you can create your S7 program within a project. The
S7 programmable controller consists of a power supply unit, a CPU, and input and
output modules (I/O modules).

The programmable logic controller (PLC) monitors and controls your machine with
the S7 program. The I/O modules are addressed in the S7 program via the
addresses.

Transferring a program

STEP 7 software

Machine to be
controlled

Input module

CPU

Power supply module

Output module

Programming
device cable

Programming device
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1.3 Basic Procedure Using STEP 7

Before you create a project, you should know that STEP 7 projects can be created
in different orders.

Option 2Option 1

If you are creating comprehensive programs with many inputs and outputs, we
recommend you configure the hardware first. The advantage of this is that STEP 7
displays the possible addresses in the Hardware Configuration Editor.

If you choose the second option, you have to determine each address yourself, depending
on your selected components and you cannot call these addresses via STEP 7.

In the hardware configuration, not only can you define addresses, but you can also change
the parameters and properties of modules. If you want to operate several CPUs, for
example, you have to match up the MPI addresses of the CPUs.

Since we are only using a small number of inputs and
outputs in the Getting Started manual, we will skip the
hardware configuration for now and start with the
programming.

Configuring the hardware
(Chapter 6)

Creating a program
(Chapters 3 to 5)

Creating a program
(Chapters 3 to 5)

Configuring the hardware
(Chapter 6)

Transferring the program to the CPU and debugging
(Chapter 7)

Designing the solution to the automation task

Creating a project (Chapter 2)
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1.4 Installing STEP 7

Regardless of whether you want to start with programming or configuring
hardware, you first have to install STEP 7. If you are using a SIMATIC
programming device, STEP 7 is already installed.

When installing the STEP 7 software
on a programming device or PC
without a previously installed version of
STEP 7, note the software and
hardware requirements. You can find
these in the Readme.wri on the
STEP 7 CD under
<Drive>:\STEP 7 \Disk1.

If you need to install STEP 7 first,
insert the STEP 7 CD in the CD-ROM
drive now. The installation program
starts automatically. Follow the
instructions on the screen.

Once the installation is complete and
you have restarted the computer, the
"SIMATIC Manager" icon will appear
on your Windows desktop.

If you double-click the "SIMATIC Manager" icon following installation, the STEP 7 Wizard
will be started automatically.

You can find additional notes on installation in the
Readme.wri file on the STEP 7 CD under

<Drive>:\STEP 7 \Disk1\Readme.wri.

If the installation does not start auto-
matically, you can also find the
installation program on the CD-ROM
under
<Drive>:\STEP 7 \Disk1\setup.exe.
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2 The SIMATIC Manager

2.1 Starting the SIMATIC Manager and Creating a Project

The SIMATIC Manager is the central window which becomes active when STEP 7
is started. The default setting starts the STEP 7 Wizard, which supports you when
creating a STEP 7 project. The project structure is used to store and arrange all
the data and programs in order.

Double-click the SIMATIC Manager
icon on the Windows desktop, then
select the File > Wizard "New
Project" menu command if the wizard
does not start automatically.

In the preview, you can toggle the
view of the project structure being
created on and off.

To move to the next dialog box, click
Next.

Within the project, data are stored in the
form of objects in a hierarchical structure

The SIMATIC station and the CPU
contain the configuration and
parameter data of the hardware

The S7 program comprises all the
blocks with the programs necessary for
controlling the machine
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For the "Getting Started" sample
project, select CPU 314. The example
has been created in such a way that
you can actually select the CPU you
have been supplied with at any time.

The default setting for the MPI address
is 2.

Click Next to confirm the settings and
move to the next dialog box.

Select the organization block OB1 (if
this is not already selected).

Select one of the programming
languages: Ladder Logic (LAD),
Statement List (STL), or Function
Block Diagram (FBD).

Confirm your settings with Next.

Every CPU has certain
properties; for example,
regarding its memory
configuration or address
areas. This is why you have
to select the CPU before you
start programming.

The MPI address (multipoint
interface) is required in order
for your CPU to communicate
with your programming device
or PC.

OB1 represents the highest
programming level and organizes the
other blocks in the S7 program.

You can change the programming
language again at a later date.
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Double-click to select the suggested
name in the "Project name" field and
overwrite it with "Getting Started."

Click Make to generate your new
project according to the preview.

When you click the Make button, the SIMATIC Manager will open with the window for the
"Getting Started" project you have created. On the following pages, we will show you what
the created files and folders are for and how you can work effectively with them.

The STEP 7 Wizard is activated each time the program is started. You can deactivate this
default setting in the first dialog box for the Wizard. However, if you create projects without
the STEP 7 Wizard, you must create each directory within the project yourself.

You can find more information under
Help > Contents in the topic "Setting
Up and Editing the Project."
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2.2 The Project Structure in the SIMATIC Manager and How
to Call the Online Help

As soon as the STEP 7 Wizard is closed, the SIMATIC Manager appears with the
open project window "Getting Started." From here, you can start all the STEP 7
functions and windows.

Downloading the program
and monitoring the
hardware

Opening, organizing, and printing
projects

Calling the STEP 7 online help

Setting the window display and
arrangement, selecting the
language, and making settings for
process data

Editing blocks and inserting program
components

The contents of the right-hand pane
show the objects and other folders
for the folder selected on the left

The contents of the left-hand pane
show the project structure
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Calling the Help on STEP 7

F1 Option 1:

Place the cursor on any menu
command and press the F1 key. The
context-sensitive help for the selected
menu command will appear.

Option 2:
Use the menu to open the STEP 7
online help.
The contents page with various help
topics appears in the left-hand pane
and the selected topic is displayed in
the right-hand pane.
Navigate to the topic you want by
clicking the + sign in the Contents list.
At the same time, the contents of the
selected topic are displayed in the
right-hand pane.
Using Index and Find, you can enter
search strings and look for the specific
topics you require.

Option 3:
Click on the "Start page" icon in the
STEP 7 Online Help to open the
information portal. This portal provides
compact access to major topics of the
Online Help, e.g.:

• Getting Started with STEP 7

• Configuring & Programming

• Testing & Debugging

• SIMATIC on the Internet

Option 4:
Click on the question mark button in
the toolbar to turn your mouse into a
help cursor. The next time you click on
a specific object, the online help is
activated.
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Navigating in the Project Structure

The project you have just created is
displayed with the selected S7 station
and CPU.

Click the + or – sign to open or close a
folder.

You can start other functions later on
by clicking the symbols displayed in
the right-hand pane.

Click the S7 Program (1) folder. This
contains all the necessary program
components.

You will use the Symbols component
in Chapter 3 to give the addresses
symbolic names.

The Source Files component is used to
store source file programs. These are
not dealt with in the Getting Started
manual.

Click the Blocks folder. This contains
the OB1 you have already created
and, later on, all the other blocks.

From here, you will start programming
in Ladder Logic, Statement List, or
Function Block Diagram in Chapters 4
and 5.

Click the SIMATIC 300 Station folder.
All the hardware-related project data
are stored here.

You will use the Hardware component
in Chapter 6 to specify the parameters
of your programmable controller.

If you require further SIMATIC software for your automation task; for example, the optional
packages PLCSIM (hardware simulation program) or S7 Graph (graphic programming
language), these are also integrated in STEP 7. Using the SIMATIC Manager, for example,
you can directly open the relevant objects such as an S7 Graph function block.

You can find more information under Help > Contents in the topics "Working
Out the Automation Concept" and "Basics of Designing the Program Structure".

You can find more information on optional packages in the SIMATIC catalog
ST 70, "Components for Completely Integrated Automation."
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3 Programming with Symbols

3.1 Absolute Addresses

Every input and output has an absolute address predefined by the hardware
configuration. This address is specified directly; that is, absolutely.

The absolute address can be replaced by any symbolic name you choose.

SF

BATF

DC 5V

FRCE

RUN

RUN P
RUN

STOP
M RES

STOP

ON

OFF

0

1

2

3

4

5

6

7

0

1

2

3

4

5

6

7

0

1

2

3

4

5

6

7

0

1

2

3

4

5

6

7

0

1

2

3

4

5

6

7

0

1

2

3

4

5

6

7

L+

L+

M M

M

N

L+ L+

M

Digital input
module
Byte 1

Bits 0 to 7

Digital input
module
Byte 0

Bits 0 to 7

Digital output
module
Byte 4

Bits 0 to 7

Digital output
module
Byte 5

Bits 0 to 7

Bit 5

Absolute address:  I 1.5

Byte 1

You should only use absolute programming if you do not
have to address many inputs and outputs in your S7
program.

Input
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3.2 Symbolic Programming

In the symbol table, you assign a symbolic name and the data type to all the
absolute addresses which you will address later on in your program; for example,
for input I 0.1 the symbolic name Key 1. These names apply to all parts of the
program and are known as global variables.

Using symbolic programming, you can considerably improve the legibility of the
S7 program you have created.

Working with the Symbol Editor

Navigate in the project window
"Getting Started" until you reach
S7 Program (1) and double-click to
open the Symbols component.

Your symbol table currently only
consists of the predefined organization
block OB1.

Click Cycle Execution and overwrite it
with "Main Program" for our example.

Enter "Green Light" and "Q 4.0" in
row 2. The data type is added
automatically.

Click in the comment column of row 1
or 2 to enter a comment on the
symbol. You complete your entries in a
row by pressing Enter, which then
adds a new row.

Enter "Red Light" and "Q 4.1" in row 3
and press Enter to complete the entry.

In this way, you can assign symbolic names to all
the absolute addresses of the inputs and outputs
which your program requires.
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Save the entries or changes you have
made in the symbol table and close the
window.

Because there are lots of names for the entire "Getting Started" project, you can
copy the symbol table to your "Getting Started" project in Section 4.1.

The data type which was previously added automatically to the symbol table determines the
type of the signal to be processed for the CPU. STEP 7 uses, among others, the following
data types:

BOOL
BYTE
WORD
DWORD

Data of this type are bit combinations. 1 bit (type BOOL) to 32 bits (DWORD).

CHAR Data of this type occupy exactly one character of the ASCII character set.
INT
DINT
REAL

They are available for the processing of numerical values (for example, to calculate
arithmetic expressions).

S5TIME
TIME
DATE
TIME_OF_DAY

Data of this type represent the different time and date values within STEP 7 (for
example, to set the date or to enter the time value for a timer).

Here you can see the symbol
table for the S7 program in the
"Getting Started" example for
Statement List.

Generally speaking, only one
symbol table is created per
S7 program, regardless of
which programming language
you have selected.

All printable characters (for
example, special characters,
spaces) are permitted in the
symbol table.

You can find more information under Help >
Contents in the topics “Programming Blocks“
and "Defining Symbols".
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4 Creating a Program in OB1

4.1 Opening the LAD/STL/FBD Program Window

Choosing Ladder Logic, Statement List, or Function Block Diagram

With STEP 7, you create S7 programs in the standard languages Ladder Logic
(LAD), Statement List (STL), or Function Block Diagram (FBD). In practice, and for
this chapter too, you must decide which language to use.

Ladder Logic (LAD)
Suitable for users from the electrical engineering industry, for example.

Statement List (STL)
Suitable for users from the world of computer technology, for example.

Function Block Diagram (FBD)
Suitable for users from the world of circuit engineering, for example.

The block OB1 will now be opened according to the language you chose
when you created it in the project Wizard. However, you can change the
default programming language again at any time.
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Copying the Symbol Table and Opening OB1

If necessary, open your "Getting
Started" project. To do this, click the
Open button in the toolbar, select the
"Getting Started" project you created,
and confirm with OK.

Depending on which programming
language you have decided to use, in
the "Sample projects" tab open one of
the following projects as well:

• ZEn01_05_STEP7__LAD_1-9

• ZEn01_01_STEP7__STL_1-9

or

• ZEn01_03_STEP7__FDB_1-9

Here you can see all three sample
projects displayed.

Navigate in the "ZEn01_XXX“ until you
reach the Symbols component and
copy this by dragging and dropping it
to the S7 Program folder in your
project window "Getting Started."

Then close the window "ZEn01_XXX“.

Double-click OB1 in the "Getting
Started" project. The LAD/STL/FBD
program window is opened.

In STEP 7, OB1 is processed cyclically by the CPU. The CPU reads line by line and
executes the program commands. When the CPU returns to the first program line, it has
completed exactly one cycle. The time required for this is known as the scan cycle time.

Depending on which programming language you have selected, continue reading in either
Section 4.2 for programming in Ladder Logic, Section 4.3 for Statement List, or Section 4.4
for Function Block Diagram.

You can find more information under Help > Contents
in the topics “Programming Blocks“ and "Creating
Blocks and Libraries.“

Drag and drop means that you click any object
with the mouse and move it whilst keeping the
mouse button depressed. When you release the
mouse button, the object is pasted at the selected
position.
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The LAD/STL/FBD Program Window

All blocks are programmed in the LAD/STL/FBD program window. Here, you can
see the view for Ladder Logic.

Program
elements
(here for
Ladder Logic)
and call
structure

Help on the selected program element

Program input line (also network
and current path)

Title and comment field for
the block or network

Toggling "Program elements" and "Call
structure" on and off

(Pane can be placed anywhere in the
program window)

Inserting a new
network

Changing the programming
language view

The most important program
elements for Ladder Logic and
Function Block Diagram

The variable declaration table contains
the parameters and local variables for
the block

Information on the selected program element

The different tabs of the  "Details" window
are for displaying error messages and
information on addresses, for editing
symbols, monitoring addresses,
comparing blocks and for editing error
definitions for the process diagnostics.
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4.2 Programming OB1 in Ladder Logic

In the following section, you will program a series circuit, a parallel circuit, and the
set / reset memory function in Ladder Logic (LAD).

Programming a Series Circuit in Ladder Logic

If necessary, set LAD as the
programming language in the View
menu.

Click in the title area of OB1 and enter
"Cyclically processed main program,"
for example.

Select the current path for your first
element.

Click the button in the toolbar and
insert a normally open contact.

In the same way, insert a second
normally open contact.

Insert a coil at the right-hand end of
the current path.

The addresses of the normally open
contacts and the coil are still missing in
the series circuit.

Check whether symbolic
representation is activated.
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Click the ??.? sign and enter the
symbolic name "Key_1" (in quotation
marks). Alternatively, you can select
the name from the displayed pull-down
list.
Confirm with Enter.

Enter the symbolic name "Key_2" for
the second normally open contact.

Enter the name "Green_Light" for the
coil.

You have now programmed a
complete series circuit.

Save the block if there are no more
symbols shown in red.

Symbols are indicated in red if, for example, they do not exist in the symbol table, or if
there is a syntax error.
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Programming a Parallel Circuit in Ladder Logic

Select Network 1.

Insert a new network.

Select the current path again.

          
Insert a normally open contact and a
coil.

Select the vertical line of the current
path.

Insert a parallel branch.

Add another normally open contact in
the parallel branch.

Close the branch (if necessary, select
the lower arrow).

The addresses are still missing in the
parallel circuit.

To assign symbolic addresses,
proceed in the same way as for the
series circuit.

Overwrite the upper normally open
contact with "Key_3," the lower contact
with "Key_4," and the coil with
"Red_Light."

Save the block.
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 Programming a Memory Function in Ladder Logic

Select Network 2 and insert another
network.

Select the current path again.

Navigate in the Program Elements
catalog under Bit Logic until you
reach the SR element. Double-click to
insert the element.

Insert a normally open contact in front
of each of the inputs S and R.

Enter the following symbolic names for
the SR element:
Upper contact "Automatic_On"
Lower contact "Manual_On"
SR element "Automatic_Mode"

Save the block and close the window.

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

You can change the line break for symbolic addressing in the LAD/STL/FBD program
window by using the menu command Options > Customize and then selecting "Width of
address field" in the "LAD/FBD" tab. Here you can set the line break between 10 and 24
characters.

Example:
Symbolic addressing in LAD

Example:
Absolute addressing in LAD

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing Ladder
Instructions."
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4.3 Programming OB1 in Statement List

In the following section, you will program an AND instruction, an OR instruction,
and the memory instruction set/reset in Statement List (STL).

Programming an AND Instruction in Statement List

If necessary, set STL as the
programming language in the View
menu.

Check whether symbolic
representation is activated.

Click in the title area of OB1 and enter
"Cyclically processed main program,"
for example.

Select the area for your first statement.

Type an A (AND) in the first program
line, a space, and then the symbolic
name "Key_1" (in quotation marks).

Complete the line with Enter. The
cursor jumps to the next line.
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In the same way, complete the AND
instruction as shown.

You have now programmed a
complete AND instruction. Save the
block if there are no more symbols
shown in red.

Programming an OR Instruction in Statement List

Select Network 1.

Insert a new network and select the
input area again.

Enter an O (OR) and the symbolic
name "Key_3" (in the same way as for
the AND instruction).

Complete the OR instruction and save
it.

Symbols are indicated in red if, for example, they do not exist in the symbol table, or
if there is a syntax error.

You can also insert the symbolic name directly from the symbol table. Click the ??.?
sign and then the menu command Insert > Symbol. Scroll through the pull-down list
until you reach the corresponding name and select it. The symbolic name is added
automatically.
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Programming a Memory Instruction in Statement List

Select Network 2 and insert another
network.

In the first line, type the instruction A
with the symbolic name
"Automatic_On."

Complete the memory instruction and
save it. Close the block.

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

Example:
Symbolic addressing in STL

Example:
Absolute addressing in STL

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing STL
Statements."



Creating a Program in OB1

4-11STEP 7 Getting Started
A5E00171228-01

4.4 Programming OB1 in Function Block Diagram

In the following section, you will program an AND function, an OR function, and a
memory function in Function Block Diagram (FBD).

Programming an AND Function in Function Block Diagram

If necessary, set FBD as the
programming language in the View
menu.

Click in the title area of OB1 and enter
"Cyclically processed main program,"
for example.

Select the input area for the AND
function (below the comment field).

               
Insert an AND box (&) and an
assignment (=).

The addresses of the elements are still
missing in the AND function.

Check whether symbolic
representation is activated.
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Click on the ??.? sign and enter the
symbolic name "Key_1" (in quotation
marks). Alternatively, you can also
select the name from the displayed
pull-down list.
Confirm with Enter.

Enter the symbolic name "Key_2" for
the second input.

Enter the name "Green_Light" for the
assignment.

You have now programmed a
complete AND function.

If there are no more symbols shown in
red, you can save the block.

Symbols are indicated in red if, for example, they do not exist in the symbol table, or
if there is a syntax error.
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Programming an OR Function in Function Block Diagram

Insert a new network.

Select the input area again for the OR
function.

                 
Insert an OR box (≥1) and an
assignment (=).

The addresses are still missing in the
OR function. Proceed in the same way
as for the AND function.

Enter "Key_3" for the upper input,
"Key_4" for the lower input, and
"Red_Light" for the assignment.

Save the block.
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Programming a Memory Function in Function Block Diagram

Select Network 2 and insert another
network. Select the input area again
(below the comment field).

Navigate in the Program Elements
catalog under Bit Logic until you
reach the SR element. Double-click to
insert the element.

"Automatic Mode"

"Automatic on"

"Manual on"

Enter the following symbolic names for
the SR element:
Set "Automatic_On"
Reset "Manual_On"
Memory bit "Automatic_Mode"

Save the block and close the window.

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

You can change the line break for symbolic addressing in the LAD/STL/FBD program
window by using the menu command Options > Customize and then selecting "Address
Field Width" in the "LAD/FBD" tab. Here you can set the line break between 10 and 24
characters.

Example:
Symbolic addressing in FBD

Example:
Absolute addressing in FBD

"Green_Light"

"Key_2"

"Key_1"

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing FBD
Statements."
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5 Creating a Program with Function Blocks
and Data Blocks

5.1 Creating and Opening Function Blocks (FB)

The function block (FB) is below the organization block in the program hierarchy. It
contains a part of the program which can be called many times in OB1. All the
formal parameters and static data of the function block are saved in a separate
data block (DB), which is assigned to the function block.

You will program the function block (FB1, symbolic name "Engine"; see symbol
table, page 3-3) in the LAD/STL/FBD program window, which you are now familiar
with. To do this, you should use the same programming language as in Chapter 4
(programming OB1).

You should have already copied the
symbol table into your project "Getting
Started." If not, read how to do this on
page 4-2, copying the symbol table,
and then return to this section.

If necessary, open the "Getting
Started" project.

Navigate to the Blocks folder and
open it.

Click in the right-hand half of the
window with the right mouse button.

The pop-up menu for the right mouse
button contains the most important
commands from the menu bar. Insert a
function block as a new object.
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Double-click FB1 to open the
LAD/STL/FBD program window.

In the "Properties – Function Block"
dialog box, select the language in
which you want to create the block,
activate the check box "Multiple
instance FB," and confirm the
remaining settings with OK.

The function block FB1 has been
inserted in the Blocks folder.

Depending on which programming language you have selected, continue reading in either
Section 5.2 for Ladder Logic, Section 5.3 for Statement List, or Section 5.4 for Function
Block Diagram.

You can find more information under Help >
Contents in the topics "Programming Blocks" and
"Creating Blocks and Libraries."
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5.2 Programming FB1 in Ladder Logic

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter a series circuit, a parallel circuit, and a
memory function with STEP 7.

Declare / Define Variables First

Your LAD/STL/FBD program window is
open and the option View > LAD
(programming language) is activated.

Note that FB1 is now in the header,
because you double-clicked FB1 to
open the program window.

The variable declaration area consists of a variable overview (left pane) and of the
variable detail view (right pane).

In the variable overview, select the declaration types "IN", "OUT" and "STAT" one
after the other and enter the following declarations into the corresponding variable
details.

In the variable overview, click the corresponding cells and apply the entries from
the subsequent figures. You can select the data type from the pull-down list
displayed.



Creating a Program with Function Blocks and Data Blocks

5-4 STEP 7 Getting Started
A5E00171228-01

Programming an Engine to Switch On and Off

Insert a normally open contact, a
normally closed contact, and an SR
element in series in Network 1 using
the corresponding buttons in the
toolbar or the Program Elements
catalog.

Then select the current path
immediately before the input R.

Insert another normally open contact.
Select the current path immediately
before this contact.

                       
Insert a normally closed contact
parallel to the normally open contact.

Only letters, numbers, and the underscore are permitted
characters for the names of the block parameters in the
variable declaration table.

If all the columns required are not displayed in your
variable details, you can display it via the shortcut menu
command (via a right-mouse click).
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Check whether symbolic
representation is activated.

Select the question marks and enter the corresponding names from the variable
declaration table (the # sign is assigned automatically).

Enter the symbolic name "Automatic_Mode" for the normally closed contact in the
series circuit.

Then save your program.

Local block variables are indicated with a # sign and are only valid in the
block.

Global variables appear in quotation marks. These are defined in the
symbol table and are valid for the entire program.

The signal state "Automatic_Mode" is defined in OB1 (Network 3; see page
4-7) by another SR element and now queried in FB1.
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Programming Speed Monitoring

Insert a new network and select the
current path.

Then navigate in the Program
Elements catalog until you reach the
Compare function and insert a
CMP>=I.

Also insert a coil in the current path.

Select the question marks again and label the coil and the comparator with the
names from the variable declaration table.

Then save your program.

When is the engine switched on and off?
When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state
"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?
The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration" or in "Editing LAD Instructions."
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5.3 Programming FB1 in Statement List

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter an AND instruction, an OR instruction, and
the set/reset memory instructions with STEP 7.

Declare / Define Variable First

Your LAD/STL/FBD program window is
open and the option View > STL
(programming language) is activated.

Note that FB1 is now in the header,
because you double-clicked FB1 to
open the program window.

The variable declaration area consists of a variable overview (left pane) and of the
variable detail view (right pane).

In the variable overview, select the declaration types "IN", "OUT" and "STAT" one
after the other and enter the subsequent declarations into the corresponding
variable details.

In the variable overview, click the corresponding cells and apply the entries from
the subsequent figures. You can select the data type from the pull-down list
displayed.
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Programming an Engine to Switch On and Off

Check whether symbolic
representation is activated.

Enter the corresponding instructions in
Network 1.

Local block variables are indicated with a # sign and
are only valid in the block.

Global variables appear in quotation marks. These
are defined in the symbol table and are valid for the
entire program.

The signal state "Automatic_Mode" is defined in
OB1 (Network 3; see page 4-10) by another SR
element and now queried in FB1.

Only letters, numbers, and the underscore are permitted
characters for the names of the block parameters in the
variable declaration table.
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Programming Speed Monitoring

Insert a new network and enter the
corresponding instructions. Then save
your program.

When is the engine switched on and off?
When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state
"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?
The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration" or in "Editing STL Statements."
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5.4 Programming FB1 in Function Block Diagram

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter an AND function, an OR function, and a
memory function with STEP 7.

Declare / Define Variables First

Your LAD/STL/FBD program window is
open and the option View > FBD
(programming language) is activated.

Note that FB1 is now in the header,
because you double-clicked FB1 to
open the program window.

The variable declaration area consists of a variable overview (left pane) and the
variable detail view (right pane).

In the variable overview, select the declaration types "IN", "OUT" and "STAT" one
after the other and enter the subsequent declarations into the corresponding
variable details.

In the variable overview, click the corresponding cells and apply the entries from
the subsequent figures. You can select the data type from the pull-down list
displayed.
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Programming an Engine to Switch On and Off

Insert an SR function in Network 1
using the Program Elements catalog
(Bit Logic folder).

Add an AND box at input S (Set), and
an OR box at input R (Reset).

Check whether symbolic
representation is activated.

Local block variables are indicated with a # sign
and are only valid in the block.

Global variables appear in quotation marks.
These are defined in the symbol table and are
valid for the entire program.
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Click the ??.? sign and enter the corresponding names from the declaration table
(the # sign is assigned automatically).

Make sure that one input of the AND function is addressed with the symbolic
name "Automatic_Mode."

Negate the inputs "Automatic_Mode" and #Fault with the corresponding button
from the toolbar.

Then save your program.

Local block variables are indicated with a # sign and are only
valid in the block.

Global variables appear in quotation marks. These are
defined in the symbol table and are valid for the entire
program.

The signal state "Automatic_Mode" is defined in OB1
(Network 3; see page 4-14) by another SR element and now
queried in FB1.
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Programming Speed Monitoring

Insert a new network and select the
input area.

Then navigate in the Program
Elements catalog under you reach the
Compare function, and insert a
CMP>=I.

Append an output assignment to the comparator and address the inputs with the
names from the variable declaration table.

Then save your program.

When is the engine switched on and off?
When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state
"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?
The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration" or in "Editing FBD Instructions."
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5.5 Generating Instance Data Blocks and Changing Actual
Values

You have just programmed the function block FB1 ("Engine") and defined, among
other things, the engine-specific parameters in the variable declaration table.

In order for you to be able to program the call for the function block in OB1 later
on, you must generate the corresponding data block. An instance data block (DB)
is always assigned to a function block.

The function block is to control and monitor a petrol or diesel engine. The different
setpoint speeds of the engines are stored in two separate data blocks, in which
the actual value (#Setpoint_Speed) is changed.

By centrally programming the function block only once, you can cut down on the
amount of programming involved.

The "Getting Started" project is open in
the SIMATIC Manager.

Navigate to the Blocks folder and click
in the right half of the window with the
right mouse button.

Insert a data block using the pop-up
menu with the right mouse button.

Apply the name DB1 in the “Properties
Data Block“ dialog box, then select the
application “Instance DB“ in the
adjacent pull-down list and apply the
name of the function block "FB1"
assigned. Apply all the settings
displayed in the "Properties" dialog box
with OK.

The data block DB1 is added to the
"Getting Started" project.

Double-click to open DB1.
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Confirm the subsequent dialog with
Yes to assign parameters to the
instance data blocks.

Next enter the value "1500" for the
petrol engine in the Actual Value
column (in the row "Setpoint_Speed).
You have now defined the maximum
speed for this engine.

Save DB1 and close the program
window.

In the same way as for DB1, generate
another data block, DB2, for FB1.

Now enter the actual value "1200" for
the diesel engine.

Save DB2 and close the program
window.

By changing the actual values, you have finished your preparations for controlling two
engines with just one function block. To control more engines, all you have to do is generate
additional data blocks.

The next thing you have to do is program the call for the function block in OB1. To do this,
continue reading in Section 5.6 for Ladder Logic, Section 5.7 for Statement List, or
Section 5.8 for Function Block Diagram, depending on the programming language you are
using.

You can find more information under Help > Contents
in the topics "Programming Blocks" and "Creating
Data Blocks."
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5.6 Programming a Block Call in Ladder Logic

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

The SIMATIC Manager is open with
your "Getting Started" project.

Navigate to the Blocks folder and
open OB1.

Select network 3 and then insert
network 4 in the LAD/STL/FBD
program window.

In the program elements catalog
navigate to FB1 and insert it via a
double-click.

Insert a normally open contact in front
of each of the following: Switch_On,
Switch_Off, and Fault.

Click the ??? sign above "Engine" and
then, keeping the cursor in the same
position, click in the input frame with
the right mouse button.

Click on Insert Symbol in the shortcut
menu via a right-click on mouse
button. A pull-down list is displayed.

OB1

Call

DB1
Petrol Engine

Data

DB2
Diesel Engine

Data

FB1
"Engine"
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Double-click the data block Petrol.
This block is then entered
automatically in the input frame in
quotation marks.

Click the question marks and after entering a quotation mark address all the other
parameters of the function block using the corresponding symbolic names in the
pull-down list.

The engine-specific input and output
variables (declaration "in" and "out")
are displayed in the FB "Engine."

A signal "PE_xxx" is assigned to
each of the variables for the petrol
engine.
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Program the call for the function block "Engine" (FB1) with the data block "Diesel"
(DB2) in a new network and use the corresponding addresses from the pull-down
list.

Save your program and close the
block.

A signal "DE_xxx" is
assigned to each of the
variables for the diesel
engine.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example,
FB1 has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File >
Archive or File > Print.

You can find more information under Help > Contents
in the topics "Calling Reference Helps" under
"Language Description: LAD," and "Program Control
Instructions."
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5.7 Programming a Block Call in Statement List

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

The SIMATIC Manager is open with
your "Getting Started" project.

Navigate to the Blocks folder and
open OB1.

Select network 3 and then insert
network 4 in the LAD/STL/FBD
program window.

Type CALL "Engine", "Petrol" in the
code section and then press Enter.

All the parameters of the function block
"Petrol" are displayed.

Position the cursor after the equals
sign of Switch_On and press the right
mouse button.

Click on Insert Symbol in the shortcut
menu via a right-click on mouse
button. A pull-down list is displayed.

OB1

Call

DB1
Petrol Engine

Data

DB2
Diesel Engine

Data

FB1
"Engine"
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Click the name Switch_On_PE. This
is taken from the pull-down list and
added automatically in quotation
marks.

Assign all the required addresses to
the variables of the function block
using the pull-down list.

Program the call for the function block
"Engine" (FB1) with the data block
"Diesel" (DB2) in a new network.
Proceed in the same way as for the
other call.

Save your program and close the
block.

A signal "PE_xxx" is assigned
to each of the variables for
the petrol engine.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example, FB1
has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File >
Archive or File > Print.

You can find more information under Help > Contents
in the topics "Calling Reference Helps" under
"Language Description: STL," and "Program Control
Instructions."



Creating a Program with Function Blocks and Data Blocks

5-21STEP 7 Getting Started
A5E00171228-01

5.8 Programming a Block Call in Function Block Diagram

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

The SIMATIC Manager is open with
your "Getting Started" project.

Navigate to the Blocks folder and
open OB1.

Select network 3 and then insert
network 4 in the LAD/STL/FBD
program window.

Then navigate in the Program
Elements catalog until you reach FB1
and insert this block.

All the engine-specific input and output
variables are displayed.

Click the ??? sign above "Engine" and
then, keeping the cursor in the same
position, click in the input frame with
the right mouse button.

Click on Insert Symbol in the shortcut
menu via a right-click on mouse
button. A pull-down list is displayed.

OB1

Call

DB1
Petrol Engine

Data

DB2
Diesel Engine

Data

FB1
"Engine"
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Double-click the data block Petrol. It is
taken from the pull-down list and
entered automatically in the input
frame in quotation marks.

Address all the other parameters of the function block using the corresponding
symbolic names in the pull-down list.

A signal "PE_xxx" is assigned
to each of the variables for the
petrol engine.
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Program the call for the function block "Engine" (FB1) with the data block "Diesel"
(DB2) in a new network and use the corresponding addresses from the pull-down
list.

Save your program and close the
block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example, FB1
has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File > Archive
or File > Print.

A signal "DE_xxx" is assigned to
each of the variables for the
diesel engine.

You can find more information under Help > Contents
in the topics "Calling Reference Helps" under
"Language Description: FBD," and "Program Control
Instructions."
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6 Configuring the Central Rack

6.1 Configuring Hardware

You can configure the hardware once you have created a project with a SIMATIC
station. The project structure which was created with the STEP 7 Wizard in
Section 2.1 meets all the requirements for this.

The hardware is configured with STEP 7. These configuration data are transferred
to the programmable controller later on "downloading" (see Chapter 7).

The starting point is the open SIMATIC
Manager together with the "Getting
Started" project.

Open the SIMATIC 300 Station folder
and double-click the Hardware
symbol.

The "HW Config“ window opens. The CPU you selected on creating the project is
displayed. For the "Getting Started" project, this is CPU 314.

Rack with individual slots

Configuration table with
the MPI and I/O
addresses

Hardware
Catalog

Help on the selected element

Short information on the
selected element
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First you require a power supply
module. Navigate in the catalog until
you reach the PS307 2A and drag and
drop this onto slot 1.

Navigate until you find the input
module (DI, Digital Input) SM321
DI32xDC24V and insert this in slot 4.
Slot 3 remains empty.

In the same way, insert the output
module SM322 DO32xDC24V/0.5A in
slot 5.

In order to change the parameters (for example, address) of a module within a
project, double-click the module. However, you should only change the
parameters if you are sure you know what effects the changes will have on your
programmable controller.

No changes are necessary for the "Getting Started" project.

The data are prepared for transfer to
the CPU using the menu command
Save and Compile.

Once you close the "HW Config"
application, the System Data symbol
will appear in the Blocks folder.

You can also check your configuration for errors using the menu command Station >
Consistency Check. STEP 7 will provide you with possible solutions to any errors which
may have occurred.

You can find more information under Help > Contents in
the topics "Configuring theHardware" and "Configuring
Central Racks."
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7 Downloading and Debugging the Program

7.1 Establishing an Online Connection

Using the supplied project "GS-LAD_Example" or the "Getting Started" project you
have created and a simple test configuration, we will show you how to download
the program to the programmable logic controller (PLC) and then debug it.

You should have:

• Configured the hardware for the "Getting Started" project (see Chapter 6)

• Set up the hardware according to the installation manual

Example of a series circuit (AND function):
Output Q 4.0 is not to light up (diode Q 4.0 lights up on the digital output module)
unless both Key I 0.1 and Key I 0.2 are pressed. Set up the test configuration
below using wires and your CPU.

Operating mode
keyswitch

RackPower supply
(on / off)

Programming device
cable

I 0.1

I 0.2

Q 4.0

Connection bridge

XX

Programming
device with
STEP 7
software

XX XX

XXXX
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Configuring the Hardware

To assemble a module on the rail, proceed in the order given below:

• Attach the module onto the bus connector

• Hang the module on the rail and swing it downwards

• Screw the module in place

• Assemble the remaining modules

• Insert the key in the CPU once you have finished assembling all the modules.

You can still carry out the test even if you are using different hardware to that shown in the
diagram. You simply have to keep to the addressing of the inputs and outputs.
STEP 7 offers you various ways of debugging your program; for example, using the
program status or by means of the variable table.

You can find more information on configuring the
central rack in the manuals "S7-300, Hardware and
Installation / Module Specifications" and "S7-400 /
M7-400 – Hardware."
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7.2 Downloading the Program to the Programmable Controller

You must have already established an online connextion in order tp download the
program...

................................................................................................................

Applying Voltage
Switch on the power supply using the
ON/OFF switch. The diode "DC 5V"
will light up on the CPU.

Turn the operating mode switch to the
STOP position (if not already in
STOP). The red "STOP" LED will light
up.

Resetting the CPU and Switching it to RUN

Turn the operating mode switch to the
MRES position and hold it there for at
least 3 seconds until the red "STOP"
LED starts flashing slowly.

Release the switch and, after a
maximum of 3 seconds, turn it to the
MRES position again. When the
"STOP" LED flashes quickly, the CPU
has been reset.

If the "STOP" LED does not start
flashing quickly, repeat the procedure.

Downloading the Program to the CPU

Now turn the operating mode switch to
"STOP" again to download the
program.

A memory reset deletes
all the data on the CPU.
The CPU is then in the
initial state.
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Start the SIMATIC Manager and open
the "Getting Started" project in the
"Open" dialog box (if it is not already
open).

In addition to the "Getting Started
Offline" window, open the "Getting
Started ONLINE" window. The online
or offline status is indicated by the
different colored headers.

Navigate in both windows to the
Blocks folder.

The offline window shows the situation
on the programming device; the online
window shows the situation on the
CPU.

Select the Blocks folder in the offline
window and then download the
program to the CPU using the menu
command PLC > Download.
Confirm the prompt with OK.

The program blocks are displayed in
the online window when you download
them.

The system functions (SFCs) remain in
the CPU even though you have carried
out a memory reset. The CPU provides
these functions of the operating system.
They do not have to be downloaded, but
they cannot be deleted.

You can also call the menu command
PLC > Download using the
corresponding button in the toolbar or
from the pop-up menu using the right
mouse button.
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Switching on the CPU and Checking the Operating Mode

Turn the operating mode switch to
RUN-P. The green "RUN" LED lights
up and the red "STOP" LED goes out.
The CPU is ready for operation.

When the green LED lights up, you
can start testing the program.

If the red LED remains lit, an error has
occurred. You would then have to
evaluate the diagnostic buffer in order
to diagnose the error.

Downloading individual blocks

In order to react to errors quickly in practice, blocks can be transferred individually to the
CPU using the drag and drop function.
When you download blocks, the operating mode switch on the CPU must be in either
"RUN-P" or "STOP" mode. Blocks downloaded in "RUN-P" mode are activated immediately.
You should therefore remember the following:
• If error-free blocks are overwritten with faulty blocks, this will lead to a plant failure. You

can avoid this by testing your blocks before you download them.
• If you do not observe the order in which blocks are to be downloaded – first the

subordinate blocks and then the higher-level blocks – the CPU will go into "STOP"
mode. You can avoid this by downloading the entire program to the CPU.

Programming online

In practice, you may need to change the blocks already downloaded to the CPU for test
purposes. To do this, double-click the required block in the online window to open the
LAD/STL/FBD program window. Then program the block as usual. Note that the
programmed block immediately becomes active in your CPU.

You can find more information under Help >
Contents and then under "Downloading and
Uploading" and under "Establishing an Online
Connection and Making CPU Settings".
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7.3 Testing the Program with Program Status

Using the program status function, you can test the program in a block. The
requirement for this is that you have established an online connection to the CPU,
the CPU is in RUN or RUN-P mode, and the program has been downloaded.

Open OB1 in the project window
"Getting Started ONLINE."

The LAD/STL/FBD program window is
opened.

Activate the function Debug >
Monitor.

Debugging with Ladder Logic

The series circuit in Network 1 is
displayed in Ladder Logic. The current
path is represented as a full line up to
Key 1 (I 0.1); this means that power is
already being applied to the circuit.

Debugging with Function Block Diagram

The signal state is indicated by "0" and
"1." The dotted line means that there is
no result of logic operation.

Debugging with Statement List

For Statement List the following is
displayed in tabular form:
– Result of logic operation (RLO)
– Status bit (STA)
– Standard status (STANDARD)

Using Options > Customize
you can change the way in
which the programming
language is represented during
testing.
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Now press both keys in your test
configuration.

The diodes for input I 0.1 and I 0.2 light
up on the input module.

The diode for output Q 4.0 lights up on
the output module.

In the graphic programming languages
Ladder Logic and Function Block
Diagram, you can trace the test result
by following the change in color in the
programmed network. This color
change shows that the result of logic
operation is fulfilled up to this point.

With the Statement List programming
language, the display in the STA and
RLO columns changes when the result
of logic operation is fulfilled.

Deactivate the function Debug >
Monitor and close the window.

Then close the online window in the
SIMATIC Manager.

We recommend you do not completely download extensive programs onto the CPU to run
them, because diagnosing errors is more difficult due to the number of possible sources of
an error. Instead, you should download blocks individually and then test them in order to
obtain a better overview.

You can find more information under Help > Contents
in the topics "Debugging" and "Testing with Program
Status."

I 0.1

I 0.2
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7.4 Testing the Program with the Variable Table

You can test individual program variables by monitoring and modifying them. The
requirement for this is that you have established an online connection to the CPU,
the CPU is in RUN-P mode, and the program has been downloaded.

As with testing with program status, you can monitor the inputs and outputs in
Network 1 (series circuit or AND function) in the variable table. You can also test
the comparator for the engine speed in FB1 by presetting the actual speed.

 Creating the Variable Table

The starting point is the SIMATIC
Manager again with the open project
window "Getting Started Offline."

Navigate to the Blocks folder and click
in the right half of the window with the
right mouse button.

Use the right mouse button to insert a
Variable Table from the pop-up menu.

Apply the default settings by closing
the "Properties" dialog box with OK.

Alternatively, you can assign a symbol
name to the variable table and enter a
symbol comment.

A VAT1 (variable table) is created in
the Blocks folder.

Double-click to open VAT1; the
"Monitoring and Modifying Variables"
window will open.
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At first, the variable table is empty. Enter the symbolic names or the addresses for
the "Getting Started" example according to the illustration below. The remaining
details will be added when you complete your entry with Enter.

Change the status format of all the speed values to DEC (decimal) format. To do
this, click the corresponding cell and select DEC format using the right mouse
button.

Save your variable table.

Switching the Variable Table Online

Click the ON button in the toolbar of
the "Monitoring and Modifying
Variables" window to establish a
connection to the configured CPU. The
word "ONLINE" will appear in the
status bar.

Set the keyswitch of the CPU to
RUN-P (if you have not already done
so).
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Monitoring Variables

Click the Monitor Variables button in
the toolbar. The operating mode of the
CPU is displayed in the status bar.

Press Key 1 and Key 2 in your test
configuration and monitor the result in
the variable table.

The status values in the variable table
will change from false to true.

Modifying Variables

Enter the value "1500" for the address MW2 in the Modify Value column and
"1300" for the address MW4.

Transfer the modify values to your
CPU.
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Following transfer, these values will be processed in your CPU. The result of the
comparison becomes visible.

Stop monitoring the variables (click the button in the toolbar again) and close the
window. Acknowledge any queries with Yes or OK.

Very large variable tables often cannot be displayed fully due to the limited screen space.
If you have large variable tables, we recommend you create several tables for one
S7 program using STEP 7. You can adapt the variable tables to precisely match your own
test requirements.
You can assign individual names to variable tables in the same way as for blocks (for
example, the name OB1_Network1 instead of VAT1). Use the symbol table to assign new
names.

You can find more information under Help > Contents
in the topics "Debugging" under "Testing with the
Variable Table."
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7.5 Evaluating the Diagnostic Buffer

If, in an extreme case, the CPU goes into STOP while processing an S7 program,
or if you cannot switch the CPU to RUN after you have downloaded the program,
you can determine the cause of the error from the events listed in the diagnostic
buffer.

The requirement for this is that you have established an online connection to the
CPU and the CPU is in STOP mode.

First turn the operating mode switch on
the CPU to STOP.

The starting point is the SIMATIC
Manager again with the open project
window "Getting Started Offline."

Select the Blocks folder.

If there are several CPUs in your
project, first determine which CPU has
gone into STOP.

All the accessible CPUs are listed in
the "Diagnosing Hardware" dialog box.
The CPU with the STOP operating
mode is highlighted.

The "Getting Started" project only has
one CPU which is displayed.

Click Module Information to evaluate
the diagnostic buffer of this CPU.

If only one CPU is connected, you can
query the module information for this
CPU directly using the menu command
PLC > Module Information.
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The "Module Information" window provides you with information on the properties
and parameters of your CPU. Now select the "Diagnostic Buffer" tab to determine
the cause of the STOP state.

The latest event (number 1) is at the top of the list. The cause of the STOP state is
displayed. Close all windows except for the SIMATIC Manager.

If a programming error caused the CPU to go into STOP mode, select the event and click
the "Open Block" button.

The block is then opened in the familiar LAD/STL/FBD program window and the faulty
network is highlighted.

With this chapter you have successfully completed the "Getting Started" sample project,
from creating a project through to debugging the finished program. In the next chapters,
you can extend your knowledge further by working through selected exercises.

You can find more information under Help > Contents
under "Diagnostics" in the topic "Calling the Module
Information."

The "Open Block" button is
disabled, because there was no
error in the block in the "Getting
Started" project.
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8 Programming a Function

8.1 Creating and Opening Functions (FC)

Functions, like function blocks, are below the organization block in the program
hierarchy. In order for a function to be processed by the CPU, it must also be
called in the block above it in the hierarchy. In contrast to the function block,
however, no data block is necessary.

With functions, the parameters are also listed in the variable declaration table, but
static local data are not permitted.

You can program a function in the same way as a function block using the
LAD/STL/FBD program window.

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

If you have worked through the
"Getting Started" sample project in
Chapters 1 to 7, open this now.

If not, create a new project in the
SIMATIC Manager using the menu
command File > "New Project"
Wizard. To do this, follow the
instructions in Section 2.1 and rename
the project "Getting Started Function."

We will continue with the "Getting
Started" project. However, you can still
carry out each step using a new
project.

Navigate to the Blocks folder and
open it.

Click in the right half of the window
with the right mouse button.



Programming a Function

8-2 STEP 7 Getting Started
A5E00171228-01

Insert a Function (FC) from the
pop-up menu.

In the "Properties – Function" dialog
box, accept the name FC1 and select
the required programming language.

Confirm the remaining default settings
with OK.

The function FC1 is added to the
Blocks folder.

Double-click to open FC1.

In contrast to the function block, no static data can be defined in the variable declaration
table for a function.

The static data defined in a function block are retained when the block is closed. Static data
can be, for example, the memory bits used for the "Speed" limit values (see Chapter 5).

To program the function, you can use the symbolic names from the symbol table.

You can find more information under Help > Contents in the
topics "Working Out the Automation Concept," "Basics of
Designing a Program Structure," and "Blocks in the User
Program".
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8.2 Programming Functions

In this section, you will program a timer function in our example. The timer function
enables a fan to switch on as soon as an engine is switched on (see Chapter 5),
and the fan then continues running for four seconds after the engine is switched
off (off-delay).

As mentioned earlier, you must specify the input and output parameters of the
function ("in" and "out" declaration) in the variable detail view.

The LAD/STL/FBD program window is open. You work with this variable detail
view in the same way as with the detail view for the function block (see Chapter
5).

Enter the following declarations:

Programming the Timer Function in Ladder Logic

      

Select the current path for entering the
Ladder instruction.

Navigate in the Program Elements
catalog until you reach the element
S_OFFDT (start off-delay timer), and
select the element.

Insert a normally open contact in front
of input S.
Insert a coil after output Q.
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Select the question marks, enter "#" and select the corresponding names.

Set the delay time at input TV of S_OFFDT. Here, S5T#4s means that a constant
has been defined with the data type S5Time#(S5T#), lasting four seconds (4s).

Then save the function and close the window.

Programming the Timer Function in Statement List

If you are programming in Statement
List, select the input area below the
network and enter the statement as
shown here.

Then save the function and close the
window.

The "#Timer_Function" is started with
the input parameter "#Engine_On." Later
on when the function is called in OB1, it
will be supplied once with the
parameters for the petrol engine and
once with the parameters for the diesel
engine (for example, T1 for
"PE_Follow_on"). You will enter the
symbolic names of these parameters
later in the symbol table.
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Programming the Timer Function in Function Block Diagram

If you are programming in Function Block Diagram, select the input area below the
network and enter the FBD program below for the timer function.

Then save the function and close the window.

In order for the timer function to be processed, you need to call the function in a block
which is higher up in the block hierarchy (in our example, in OB1).

You can find more information under Help >
Contents in the topics "Calling Reference Helps,"
"The STL, FBD, or LAD Language Description,"
and "Timer Instructions."
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8.3 Calling the Function in OB1

The call for the function FC1 is carried out in a similar way to the call for the
function block in OB1. All the parameters of the function are supplied in OB1 with
the corresponding addresses of the petrol or diesel engine.

Since these addresses are not yet defined in the symbol table, the symbolic
names of the addresses will now be added.

The SIMATIC Manager is open with
the "Getting Started" project or your
new project.

Navigate to the Blocks folder and
open OB1.

The LAD/STL/FBD program window
opens.

Programming the Call in Ladder Logic

You are in LAD view. Select network
No. 5 and insert a new network No. 6.

Then navigate in the Program
Elements catalog until you reach FC1
and insert the function.

Insert a normally open contact in front
of "Engine_On."

Click the question marks for the FC1 call and insert the symbolic names.

An address is part of a STEP 7 statement and specifies
what the processor should execute the instruction on.
Addresses can be absolute or symbolic.

Using the menu command View >
Display > Symbolic Representation,
you can toggle between symbolic and
absolute addresses.
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Program the call for the function FC1 in Network 7 using the addresses for the
diesel engine. You can do this in the same way as for the previous network (you
have already added the addresses for the diesel engine to the symbol table).

Save the block and then close the
window.

Activate the menu command View >Display > Symbol
Information to view the information on individual addresses in
each network.

To display several networks on the screen, deactivate the menu
command View > Display > Comment and, if necessary View >
Display > Symbol Information.

Using the menu command View > Zoom Factor, you can
change the size of the networks displayed.
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Programming the Call in Statement List

If you are programming in Statement
List, select the input area below a new
network and enter the STL statements
shown here.

Then save the call and close the
window.

Programming the Call in Function Block Diagram

If you are programming in Function Block Diagram, select the input area below a
new network and enter the FBD instructions shown below.

Then save the call and close the window.

The call for the functions was programmed as an unconditional call in our example; that is,
the function will always be processed.

Depending on the requirements of your automation task, you can make the call for a
function or function block dependent on certain conditions; for example, an input or a
preceding logic operation. The EN input and the ENO output are provided in the box for
programming conditions.

You can find more information under Help >
Contents and then under "Calling Reference
Helps," in the topics "The LAD, FBD, or STL
Language Description".
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9 Programming a Shared Data Block

9.1 Creating and Opening Shared Data Blocks

If there are not enough internal memory bits in a CPU to save all the data, you can
store specific data in a shared data block.

The data in a shared data block are available to every other block. An instance
data block, on the other hand, is assigned to one specific function block, and its
data are only available locally in this function block (see Section 5.5).

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

If you have worked through the
"Getting Started" sample project in
Chapters 1 to 7, open this now.

If not, create a new project in the
SIMATIC Manager using the menu
command File > "New Project"
Wizard. To do this, follow the
instructions in Section 2.1 and rename
the project "Getting Started Function."

We will continue with the "Getting
Started" project. However, you can still
carry out each step using a new
project.

Navigate to the Blocks folder and
open it.

Click in the right half of the window
with the right mouse button.
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Insert a Data Block (DB) from the
pop-up menu.

In the "Properties – Data Block" dialog
box, accept all the default settings with
OK.

Use the "Help“ Button for further
information.

The data block DB3 has been added to
the Blocks folder.

Double-click to open DB3.

Programming Variables in the Data Block

Enter "PE_Actual_Speed" in the Name
column.

Click with the right mouse button to
select the type using the menu
command Elementary Types > INT
from the pop-up menu.

In the example below, three shared data are defined in DB3. Enter these data
accordingly in the variable declaration table.

Save the shared data block.

Remember: In Section 5.5, you
generated an instance data block by
activating the option "Data block
referencing a function block." In
contrast, using "Data block" you
create a shared data block.

The variables for the actual speeds in the data block
"PE_Actual_Speed" and "DE_Actual_Speed" are treated
in the same way as the memory words MW2
(PE_Actual_Speed) and MW4 (DE_Actual_Speed). This
can be seen in the next chapter.
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Assigning Symbols

You can also assign symbolic names
to data blocks.

Open the Symbol Table and enter the
symbolic name "S_Data" for the data
block DB3.

Save the symbol table and close the
"Symbol Editor" window.

Also close the shared data block.

Shared data blocks in the variable declaration table:

Using the menu command View > Data View, you can change the actual values of the data
type INT in the table for the shared data block (see Section 5.5).

Shared data blocks in the symbol table:

In contrast to the instance data block, the data type for the shared data block in the symbol
table is always the absolute address. In our example, the data type is "DB3." With the
instance data block, the corresponding function block is always specified as the data type.

You can find more information under Help > Contents in the topics
"Programming Blocks" and "Creating Data Blocks."

If you copied the symbol table from a sample
project (zEn01_02_STEP7__STL_1-10,
zEn01_06_STEP7__LAD_1-10 or
zEn01_04_STEP7__FBD_1-10) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.
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10 Programming a Multiple Instance

10.1 Creating and Opening a Higher-Level Function Block

In Chapter 5 you created a program for controlling an engine with the function
block "Engine" (FB1). When the function block FB1 was called in the organization
block OB1, it used the data blocks "Petrol" (DB1) and "Diesel" (DB2). Each data
block contained the different data for the engines (for example, #Setpoint_Speed).

Now imagine that you require other programs to control the engine for your
automation task; for example, a control program for a rapeseed oil engine, or a
hydrogen engine, etc.

Following the procedure you have learned so far, you would now use FB1 for each
additional engine control program and assign a new data block each time with the
data for this engine; for example, FB1 with DB3 to control the rapeseed oil engine,
FB1 with DB4 for the hydrogen engine, etc. The number of blocks would increase
significantly as you created new engine control programs.

By working with multiple instances, on the other hand, you can reduce the number
of blocks. To do this, you create a new, higher-level function block (in our example,
FB10), and call the unchanged FB1 in it as a "local instance." For each call, the
subordinate FB1 stores its data in data block DB10 of the higher-level FB10. This
means that you do not have to assign any data blocks to FB1. All the function
blocks refer back to a single data block (here DB10).

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

The data blocks DB1 and DB2 are integrated in DB10. To do
this, you must declare FB1 in the static local data of FB10.

OB1
CALL FB10, DB10

FB10
CALL FB1 (for petrol engine)
CALL FB1 (for diesel engine)
. . .

DB10
"Petrol engine" data
"Diesel engine" data

FB1
"Engine"

FB1
"Engine"
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If you have worked through the
"Getting Started" example in Chapters
1 to 7, open the "Getting Started"
project.

If not, open one of the following
projects in the SIMATIC Manager:
ZEn01_05_STEP7__LAD_1-9  for
Ladder Logic,
ZEn01_01_STEP7__STL_1-9 for
Statement List
ZEn01_03_STEP7__FBD_1-9  for
Function Block Diagram.

Navigate to the Blocks folder and
open it.

Click with the right mouse button in the
right half of the window and insert a
function block using the pop-up menu.

Change the name of the block to FB10
and select the required programming
language.

Activate Multiple instance FB (if
necessary) and accept the remaining
default settings with OK.

FB10 has been added to the Blocks
folder. Double-click to open FB10.

You can create multiple instances for any function block, even for valve control programs,
for example. If you want to work with multiple instances, note that both the calling and the
called function blocks must have multiple instance capability.

You can find more information under Help > Contents in the topics
"Programming Blocks" and "Creating Blocks and Libraries."
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10.2 Programming FB10

To call FB1 as a "local instance" of FB10, in the variable detail view a static
variable must be declared with a different name for each planned call of FB1.
Here, the data type is FB1 ("Engine").

Declare / Define Variables

FB10 is open in the LAD/STL/FBD program window. Transfer the declarations of
the subsequent image to your variable detail view. To do this, select the
declaration types "OUT", "STAT" and "TEMP" one after the other and make your
entries in the variable detail view. Select "FB <nr>" as the data type for the
declaration type "STAT" from the pull-down list and replace the character string
"<nr>" with the "1".

The declared local instances will then appear in the
"Program elements" tab under "Multiple Instances."
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Programming FB10 in Ladder Logic

Insert the call "Petrol_Engine" as the
multiple-instance block
"Petrol_Engine" in Network 1.

Then insert the required normally open contacts and complete the call with the
symbolic names.

Insert a new network and program the call for the diesel engine. Proceed in the
same way as for Network 1.

The "Actual_Speed" for the engines is not
taken from a memory bit (see Section 5.6
onwards), but from a shared data block
(see Section 9.1). The general address
assignment is as follows:
"Data_Block".Address, for example:
"S_Data".PE_Actual_Speed.
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Insert a new network and program a series circuit with the corresponding
addresses. Then save your program and close the block.

Use the respective temporary
variables. You will recognize the
temporary variables in the pull-down
menu by the symbols displayed on the
left.

Then save your program and close the
block.

Programming FB10 in Statement List

If you are programming in Statement
List, select the input area under a new
network and enter the STL instructions
shown here.

Then save your program and close the
block.

The temporary variables
("PE_Setpoint_Reached" and
"DE_Setpoint_Reached") are
supplied to the output parameter
"Setpoint_Reached," which is then
processed further in OB1.
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Programming FB10 in Function Block Diagram

If you are programming in Function Block Diagram, select the input area under a
new network and enter the FBD instructions below.

Then save your program and close the block.

To edit both calls for FB1 in FB10, FB10 must be called itself.

Multiple instances can only be programmed for function blocks. Creating multiple instances
for functions (FCs) is not possible.

You can find more information under Help > Contents in the
topics "Programming Blocks," "Creating Logic Blocks," and
"Multiple Instances in the Variable Declaration."
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10.3 Generating DB10 and Adapting the Actual Value

The new data block DB10 will replace the data blocks DB1 and DB2. The data for
the petrol engine and the diesel engine are stored in DB10 and will be required
later for calling FB10 in OB1 (see "Calling FB1 in OB1" from Section 5.6 onwards).

Create the data block DB10 in the
Blocks folder of the "Getting Started"
project in the SIMATIC Manager using
the pop-up menu.

To do this, change the name of the
data block to DB10 in the dialog box
"Properties - Data Block", then select
the application "Instance DB" in the
adjacent pull-down list". In the right
pull-down list, select the function block
"FB10" to be assigned and confirm the
remaining settings with OK.

The data block DB10 has been added
to the "Getting Started" project.

Double-click on DB10..

In the following dialog box, answer with
Yes to open the instance DB. Select
the menu command View > Data
View.

The data view displays each individual
variable in DB10, including the "internal"
variables of the two calls for FB1 ("local
instances").

The declaration view displays the variables
as they are declared in FB10.
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Change the actual value of the diesel engine to "1300," save the block, and then
close it.

All the variables are now contained in the variable declaration table of DB10. In the first half,
you can see the variables for calling the function block "Petrol_Engine" and in the second
half the variables for calling the function block "Diesel_Engine" (see Section 5.5).

The "internal" variables of FB1 retain their symbolic names; for example, "Switch_On." The
name of the local instance is now placed in front of these names; for example,
"Petrol_Engine.Switch_On."

You can find more information under Help > Contents in the
topics "Programming Blocks" and "Creating Data Blocks."
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10.4 Calling FB10 in OB1

The call for FB10 is made in OB1 in our example. This call represents the same
function which you have learned while programming and calling FB1 in OB1 (see
Section 5.6 onwards.). Using multiple instances, you can replace Networks 4 and
5 programmed from Section 5.6 onwards.

Open OB1 in the project in which you
have just programmed FB10.

Defining Symbolic Names

The LAD/STL/FBD program window is open. Open the symbol table using the
menu command Options > Symbol Table and enter the symbolic names for the
function block FB10 and the data block DB10 in the symbol table.

Then save the symbol table and close the window.

Programming the Call in Ladder Logic

Insert a new network at the end of OB1
and add the call for FB10 ("Engines").

If you copied the symbol table from a sample
project (ZEn01_01_STEP7__STL_1-10,
ZEn01_05_STEP7__LAD_1-10 or
ZEn01_03_STEP7__FBD_1-10) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.
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Complete the call below with the corresponding symbolic names.
Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.
Then save your program and close the block.

Programming the Call in Statement List

If you are programming in Statement List, select the input area under the new
network and enter the STL instructions below. To do this, use the FB Blocks >
FB10 Engines in the Program Elements catalog.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.

Then save your program and close the block.

The output signal "Setpoint_Reached" for FB10
("Engines") is passed on to the variable in the
shared data block.
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Programming the Call in Function Block Diagram

If you are programming in Function Block Diagram, select the input area under the
new network and enter the FBD instructions below. To do this, use the FB Blocks
> FB10 Engines in the Program Elements catalog.
Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.
Then save your program and close the block.

If you require additional engine control programs for your automation task; for example, for
gas engines, hydrogen engines, etc., you can program these as multiple instances in the
same way and call them from FB10.

To do this, declare the additional engines as shown in the variable declaration table of FB10
("Engines") and program the call for FB1 in FB10 (multiple instance in the Program
Elements catalog). You can then define the new symbolic names; for example, for the
switch-on and switch-off procedures in the symbol table.

You can find more information under Help > Contents and
then under "Calling References Helps" in the topics "The STL,
FBD, or LAD Language Description".
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11 Configuring the Distributed I/O

11.1 Configuring the Distributed I/O with PROFIBUS DP

Automation systems with conventional configurations have the cable connections
to the sensors and actuators inserted directly into the I/O modules of the central
programmable logic controller. This often means a considerable amount of wiring
is involved.
Using a distributed configuration, you can considerably reduce the amount of
wiring involved by placing the input and output modules close to the sensors and
actuators. You can establish the connection between the programmable logic
controller, the I/O modules, and the field devices using the PROFIBUS DP.
You can find out how to program a conventional configuration in Chapter 6. It
makes no difference whether you create a central configuration or a distributed
configuration. You select the modules to be used from the hardware catalog,
arrange them in the rack, and adapt their properties according to your
requirements.
It would be an advantage when reading this chapter if you have already
familiarized yourself with creating a project and programming a central
configuration (see Section 2.1 and Chapter 6).

PROFIBUS-DP network
between master and
slaves

Master device:
for example, CPU 315-2DP

Modular slaves:
for example, ET 200 M-IM153

Compact slaves:
for example, I/O modules
ET 200B-16DI / 16DO

Direct connection between
CPU and programming
device / PC via MPI
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Creating a New Project

The starting point is the SIMATIC
Manager. To make things easier to
follow, close any open projects.

Create a new project.

Select the CPU 315-2DP in the
corresponding dialog box (CPU with
PROFIBUS-DP network).

Now proceed in the same way as for
Section 2.1 and assign the project the
name "GS-DP" (Getting Started –
Distributed I/O).

If you want to create your own
configuration at this point, specify your
CPU now. Note that your CPU must
support distributed I/Os.

Inserting the PROFIBUS Network

Select the folder GS-DP.

Insert the PROFIBUS network using
the right mouse button in the right half
of the window.
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Configuring the Station

Select the folder SIMATIC 300 Station
and double-click Hardware.
The "HW Config" window is opened
(see Section 6.1).

The CPU 315-2 DP already appears in
the rack. If necessary, open the
Hardware catalog using the menu
command View > Hardware Catalog
or the corresponding button in the
toolbar.

Drag and drop the power supply
module PS307 2A into slot 1.

In the same way, insert the I/O
modules DI32xDC24V and
DO32xDC24V/0.5A in slots 4 and 5.

In addition to the CPU which supports the
distributed I/O, you can also place other CPUs in
the same rack (not described here).
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Configuring the DP-Master System

Select the DP master in slot 2.1 and
insert a DP-master system.

Apply the suggested address "1" in the
dialog box displayed. Select
"PROFIBUS(1)" in the "Subnet" field
and then apply your settings with OK.

Navigate in the Hardware catalog until
you reach the module B-16DI and
insert this module in the master system
(drag the object to the master system
until the cursor changes to a "+" sign;
then drop the object).

You can change the node address of
the module you have inserted in the
"Parameters" tab of the "Properties"
dialog box.
Confirm the suggested address 1 with
OK.

You can now move any objects which you
place in the master system by dragging
them with the left mouse button held down.
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In the same way, drag and drop the
module B-16DO onto the master
system.

The node address is automatically
adapted in the dialog box. Confirm this
entry with OK.

Drag and drop the interface module
IM153 onto the master system and
confirm the node address again with
OK.

Select the ET200M in the network.
The free slots for the ET200M are
displayed in the lower configuration
table.

Select slot 4 here.

The ET200M itself can have additional
I/O modules. Select, for example, the
module DI32xDC24V for slot 4 and
double-click this module to insert it.

In our example, we are using the default
node addresses. However, you can change
these addresses at any time to meet your
requirements.

You should always make sure that you are in
the right folder when using the Hardware
catalog. For example, navigate to the
ET200M folder to select modules for the
ET200M.
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Changing the Node Address

In our example, we do not need to
change the node address. In practice,
however, this is often necessary.

Select the other nodes one after
another and check the input and output
addresses. The "Configuring
Hardware" application has adapted all
the addresses, so there are no double
assignments.

Let us imagine that you want to
change the address of the ET200M:

Select the ET200M and double-click
DO32xDC24V/0.4A (slot 4).

Now change the input addresses in the
"Addresses" tab of the "Properties"
dialog box from 6 to 12.
Close the dialog box with OK.
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Finally, save and compile the
distributed I/O configuration.

Close the window.

Optional: Configuring Networks

You can also configure the distributed
I/O using the optional package
"Configuring Networks."

Double-click the network PROFIBUS
(1) in the SIMATIC Manager.

The "NETPRO" window is opened.

You can drag and drop additional
DP slaves onto the PROFIBUS DP
from the catalog of network objects.

Double-click any element to configure
it. The "Configuring Hardware" window
is opened.

Using the menu commands Station > Consistency Check ("Configuring Hardware"
window) and Network > Consistency Check ("Configuring Networks" window), you can
check the configuration for errors before saving. Any errors are displayed and STEP 7 will
suggest possible solutions.

You can find more information under Help > Contents in the topics
"Configuring the Hardware" and "Configuring the Distributed I/O."

The menu command Save and Compile means that the
configuration is automatically checked for consistency. If
there are no errors, the system data are generated and can
be downloaded to the programmable controller.

With Save, you can save the configuration even if it
contains errors. However, you cannot then download the
configuration to the programmable controller.
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Congratulations! You have worked through the Getting Started manual and learned the most
important terms, procedures, and functions of STEP 7. Now you can get started on your first
project.

If, while working on future projects, you are looking for specific functions or have forgotten any
of the operating instructions in STEP 7, you can use our comprehensive Help on STEP 7.

If you want to extend your knowledge of STEP 7, there are a number of specialized training
courses available. Your local Siemens representative will be happy to help you.

We wish you lots of success with your projects!

Siemens AG
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Appendix A

Overview of the Sample Projects for the Getting Started Manual

• ZEn01_02_STEP7__STL_1-10:
The programmed Chapters 1 to 10 including the symbol table in the STL
programming language.

• ZEn01_01_STEP7__STL_1-9:
The programmed Chapters 1 to 9 including the symbol table in the STL
programming language.

• ZEn01_06_STEP7__LAD_1-10:
The programmed Chapters 1 to 10 including the symbol table in the LAD
programming language.

• ZEn01_05_STEP7__LAD_1-9:
The programmed Chapters 1 to 9 including the symbol table in the LAD
programming language.

• ZEn01_04_STEP7__FBD_1-10:
The programmed Chapters 1 to 10 including the symbol table in the FBD
programming language.

• ZEn01_03_STEP7__FBD_1-9:
The programmed Chapters 1 to 9 including the symbol table in the FBD
programming language.

• ZEn01_07_STEP7__Dist_IO:
The programmed Chapter 11 with the distributed I/O.
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Software packages and 
options

Intro

With the TIA Portal, machine builders and system 
integrators as well as plant operators will benefit 
from: 
•  shorter time to market thanks to innovative 

simulation tools, among other things
•  increased plant productivity thanks to  

additional diagnostic and energy management 
functions 

•  greater flexibility thanks to coordinated team-
work

The Totally Integrated Automation Portal (TIA 
Portal) enables complete access to the entire digi-
talized automation, from digital planning and 
integrated engineering to transparent operation. 
As part of the Digital Enterprise Software Suite, it 
joins PLM and MES in rounding out the compre-
hensive offering from Siemens for companies on 
the path to Industrie 4.0, making it the perfect 
access to automation in the Digital Enterprise.  

TIA Portal – 
more than an 
engineering 
framework
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Added values

Open, virtual  
and connected
Digital workflow with TIA Portal

“The ability to simulate machines gives me security 
in design, security in sales and security in machine 
configuration.”
Rainer Feuchter,  
CEO Optima Consumer GmbH

Flexible simulation
By simulating the entire installation, including 
the controller and HMI, and by evaluating it  
based on a virtual model, local commissioning 
time is reduced thanks to PLCSIM Advanced, the 
controller’s digital twin.

Open system
TIA Portal allows you to efficiently create your 
project using software generators, thus reducing 
the number of redundant workflows. With 
Teamcenter, you also merge the project versions 
from planning, engineering and design.

Seamless connectivity
The cloud offers new possibilities in engineering 
as well as for the operation of plants. The TIA 
Portal Cloud Connector makes it possible to work 
with the TIA Portal regardless of the location or 
device. For you, this means greater flexibility and 
less installation effort. During operation, you can 
benefit from additional digital services thanks to 
the connection of plants to the Siemens Mind-
Sphere Cloud.
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Added values

Shorten your  
time to market
Integrated engineering with TIA Portal

“You work with a team-enabled, fully integrated  
tool landscape with access to a complete portfolio  
of necessary control and drive components.”
Andreas Martin Linck,  
Head of E-Technik

One for all
With TIA Portal, you integrate all important  
components of your automation project: safety, 
security, control, HMI, drives, distributed I/O and 
now even motion control and power distribution. 
With only a few multiple entries, a shared data-
base and a standard interface across all tasks, 
your engineering time is reduced.

Coordinated teamwork
With TIA Portal Multiuser Engineering, multiple 
people can access a project at the same time. 
Synchronization is automatic. You can flexibly 
process tasks and complete them simultaneously 
– both device-oriented and task-based.
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Reliably avoid errors
You reduce the amount of extra work by reliably 
identifying errors and quickly correcting them 
with numerous programming code templates. 
Many new and efficient diagnostic tools as well 
as cyclical system test recordings provide help in 
analyzing sporadic errors during commissioning.

Handle know-how safely and efficiently
Thanks to the comprehensive library concept, you 
can easily reuse all project objects and thus avoid 
extra work. Safeguard your specialist knowledge 
over the long term with know-how-protected 
blocks, and easily further develop existing sys-
tems and projects in TIA Portal.

Generation instead of programming
Develop your solutions even faster thanks to  
automatic generation of HMI visualization with 
SiVArc, fast and easy machine and plant diagnos-
tic, efficient energy management system imple-
mentation as well as automatic program creation 
using software generators that are linked via the 
TIA Portal Openness interface.
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Increase your  
productivity
Transparent operation with TIA Portal

“A standard engineering platform is desirable for  
engineering energy efficiency systems: consistently 
from the device to the configuration to data storage, 
all the way to the customer’s desk.”
Stephan Vömel, 
Proprietor and managing director, Quintec Automatisierungs- und  
Datentechnik GmbH

Information management
The greatest possible transparency through con-
sistent data storage in production lets you make 
the right decisions quickly. You can prepare data 
according to specific target groups with the  
SIMATIC Information Server locally or on a mobile 
device when you are in the field. The system sup-
ports WinCC/WebUX as well as WebNavigator for 
remote access and control.

Energy management
The integrated SIMATIC Energy Suite automation 
solution and the universally connected Energy 
Manager PRO energy management system help 
you get a handle on your energy costs at all 
times. The Energy Suite makes energy data re-
cord easy and efficient and gives you the trans-
parency you need to save energy according to 
ISO 50001.
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Diagnosis management
Efficient and integrated diagnosis of process er-
rors reduce production downtimes and increase 
the availability of your machines and plants. The 
standardized ProDiag machine and plant diagnos-
tic function gives you efficient analyses of pro-
cess errors. Integrated system diagnosis helps 
you quickly identify errors in the automation  
system across all system components.

User management 
Efficient user management is a key part of every 
security concept. User management in the TIA 
Portal enables system-wide, central maintenance 
of users, including an optional connection to 
Windows Active Directories. The person-specific 
assignment of roles and authorizations minimizes 
maintenance effort while achieving a high degree 
of transparency. This provides a solid foundation 
for efficient and consistent administration of  
personalized access rights in the plant, which 
significantly reduces security risks.

Open communication 
Connecting automation and IT level by means of 
open communication makes it easy to integrate 
higher-level MES/ERP solutions. The standardized 
OPC UA communication protocol lets you forward 
production data to systems of other manufactur-
ers. Industrial Data-Bridge is used for bidirection-
al, cross-system communication via standard  
interfaces, without any programming work.
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Options

Digitalization and the TIA Portal cluster
TIA Portal options provide answers to customer requirements

TIA Portal options
SIMATIC S7-PLCSIM Advanced
Comprehensive simulation of the controller functionality including 
interaction with virtual plant and machine models

TIA Portal Cloud Connector
Boost the flexibility in your daily work through engineering in your 
private cloud

TIA Portal Teamcenter Gateway
Safeguarding projects plant-wide with the storage of TIA Portal 
projects in Teamcenter

SIMATIC Target 1500S for SIMULINK 
The software development can be integrated directly into the STEP 7 
program through the automatic generation of executable code

TIA Portal Multiuser Engineering
Work together on a project as a team and manage it flexibly on a server.  
Centrally track changes with user comments and versions in one location

SIMATIC ODK 1500S
Supports the development of Windows and real-time functions and 
provides for the integration of high-level languages

SIMATIC STEP 7 Safety 
Provides for the seamless integration of machine safety into the 
SIMATIC automation system

SIMATIC Visualization Architect SiVArc
Implement standardized HMI visualizations with even greater  
efficiency through automatic generation

SIMATIC OPC UA
Open communication standard for the communication concepts of 
Industrie 4.0

SIMATIC Energy Suite
Energy transparency in production thanks to automatic creation  
and intuitive configuration

SIMATIC ProDiag
Diagnosis of application errors reduces production downtimes and 
increases the availability of your machines and plants

WinCC/WebUX1

Diagnosis of application errors reduces production downtimes and 
increases the availability of your machines and plants

TIA User Management Component
Reduction of security risks thanks to the efficient and consistent  
administration of personalized access rights in the plant

Open, virtual, and networked 
Digital workflow with TIA Portal

Shorten your time to market  
Integrated engineering with TIA Portal

Increase your productivity  
Transparent operation with TIA Portal

1Part of WinCC Runtime Professional

http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/step7-tia-portal/simatic-step7-options/s7-plcsim-advanced/Pages/Default.aspx
https://www.industry.siemens.com/topics/global/en/tia-portal/software/details/Pages/tia-portal-cloud.aspx
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/tia-portal-options/tia-portal-teamcenter-gateway/Pages/Default.aspx
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/step7-tia-portal/simatic-step7-options/target-1500s-for-simulink/Pages/Default.aspx
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/tia-portal-options/tia-portal-multiuser-engineering/Pages/Default.aspx
https://w3.siemens.com/mcms/programmable-logic-controller/en/software-controller/s7-1500-software-controller-odk/Pages/Default.aspx
https://www.industry.siemens.com/topics/global/en/safety-integrated/machine-safety/product-portfolio/automation-systems/factory-safety/Pages/default.aspx
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/tia-portal-options/sivarc/Pages/Default.aspx
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/step7-tia-portal/simatic-step7-options/opc-ua-s7-1500/Pages/Default.aspx
https://www.siemens.com/global/en/home/products/automation/industry-software/automation-software/energymanagement/simatic-energy-suite.html
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/tia-portal-options/simatic-prodiag/Pages/Default.aspx
http://w3.siemens.com/mcms/automation-software/en/tia-portal-software/wincc-tia-portal/wincc-tia-portal-options/wincc-web-ux/Pages/Default.aspx
https://www.siemens.com/global/en/home/company/topic-areas/future-of-manufacturing/industrial-security.html
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Easy access to the  
TIA Portal

Optionen

 Action packages
Trial user
TIA Portal V14 TRIAL download collections
www.siemens.com/tia-portal-trial
Trial period: limited (21 days)

Upgraders
Software – STEP 7 V5.5 to SIMATIC STEP 7 Professional V15 Combo
Scope: Upgrade and power pack from STEP 7 V5.x to STEP 7 V15 Professional / Prof. 2017; SUS contract also required
Product no.: 6ES7822-1AE05-0XC2
SUS product no.: 6ES7810-5CC04-0YY2  
Trial period: unlimited; prerequisites: STEP 7 V5.x license, STEP 7 V5.5 SUS
Important: The package is linked with a mandatory SUS contract.

First-time users
Starter kit with S7-1500 hardware
The starter kit includes everything you need to immediately put the high-performance SIMATIC S7-1500 into use.
www.siemens.com/s7-1500-starter-kits
Starter kit with S7-1200 hardware
With the SIMATIC S7-1200 starter kits, you can quickly and easily implement your simple automation tasks.
www.siemens.com/s7-1200-starterkits
Starter kit with Comfort Panel hardware
With high-resolution wide-screen displays ranging from 4" to 22" and the option of touch operation or operating buttons, the starter kits include 
everything you need to use the hardware.
www.siemens.com/comfort-panel-starter-kits
Software – SIMATIC STEP 7 Professional V15 power pack: V15 Trial 365 → V15 (download)
After you purchase the SIMATIC S7-1500 starter kit, you can convert the included 365-day license to a full license of the same version with a  
power pack.
Product no.: 6ES7822-1BE05-0YC5
Prerequisites: S7-1500 starter kit

Temporary use
SIMATIC 50-h engineering license for infrequent use of the software (rental license)
Scope: STEP 7 Professional (TIA Portal & 2017), WinCC Professional (TIA Portal & WinCC flexible 2008), STEP 7 Safety Advanced  
(TIA Portal & Distributed Safety)
Product no.: 6ES7823-1GE05-0YA5
Trial period: 50 hours of actual use

Easy access to the TIA Portal

http://www.siemens.com/s7-1500-starter-kits
http://www.siemens.com/s7-1200-starterkits
http://www.siemens.com/comfort-panel-starter-kits
http://www.siemens.com/tia-portal-trial
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Software Update Service (SUS)
With the Software Update Service, you automatically receive all released versions of the software you use delivered right to your door – in other 
words, all upgrades and service packs. 
www.siemens.com/SUS
Online Software Delivery (OSD)
The clever alternative to traditional software delivery! Downloading automation software reduces your administrative expense and storage costs, 
and ensures simple, reliable, and always clearly organized license management.
www.siemens.com/OSD 

Your step into the future – migration made easy
Supporting documents and tools for migration
Migration to the TIA Portal is supported with several powerful tools and helpful documents, which you can simply download.
•  TIA Portal readydiness check tool: Check quickly and easily whether the hardware contained in your projects is supported by the TIA Portal. 

Readiness-check (weblink)
•  Compatibility tool: The tool allows you to assemble a compatible selection of software products or to check existing configurations for compatibility.  

www.siemens.com/kompatool

Individual modernization support Documentation
On request, Siemens can provide you with personal support for very specific requirements:  
www.siemens.com/industry/contact 
www.siemens.com/fa-services
From consultation and implementation to final project completion, Siemens offers com-
prehensive modernization services: 
www.siemens.com/fa-migration
Details are available at:  
www.siemens.com/tia-migration

Migration guides (weblinks) 
   From SIMATIC S7-300/400 to S7-1500  

   From SIMATIC S5 to S7-1500  

   From SIMATIC WinAX RTX to  
S7-1500 Software Controller 

On the path to the digital enterprise – discover your potential with training courses for SIMATIC S7-1500 training in the TIA Portal 

Industry is undergoing rapid developments that are being further accelerated by digitalization. The technologies today are so complex that continu-
ous education and regular courses on training equipment are essential in order to keep skills up to date.
We offer you product training tailored to match all topic areas so that you can get the most from the capabilities of the extensive SIMATIC range of 
products. The training covers the entire life cycle of your plant. SIMATIC S7 service and programming training form the core of product training. The 
course content covers not only the main topics of SIMATIC S7-1500 in the TIA Portal but also includes programming languages, operator control and 
monitoring systems, drive technology, industrial communication and safety technology. 
siemens.com/sitrain-tiaportal

http://www.siemens.com/SUS
https://support.industry.siemens.com/cs/document/60162195/tia-portal-readiness-check-tool?dti=0&lc=en-WW
http://www.siemens.com/kompatool
http://www.siemens.com/industry/contact
http://www.siemens.com/fa-services
http://www.siemens.com/fa-migration
http://www.siemens.com/tia-migration
https://support.industry.siemens.com/cs/document/109478811/migration-guide%3A-simatic-s7-300-400-to-simatic-s7-1500?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/105106251/migration-guide%3A-simatic-s5-to-simatic-s7-1500?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109478804/guide-for-migrating-pc-based-controllers%3A-from-simatic-winac-rtx-to-the-simatic-s7-1500-software-controller-and-tia-portal?dti=0&lc=en-WW
http://www.siemens.com/OSD
http://www.siemens.com/sitrain-tiaportal
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Siemens automation tasks
Efficient automation begins with efficient engineering. Consistent, end-to-end engineering enables savings with regard to time, 
costs, and effort. Based on specific tasks, our web tutorials show you how you can reduce your project planning time in your daily 
work. In addition, you can increase the profitability of engineering projects and improve your competitiveness. We ensure that step 
by step, you will arrive at a result in less than 10 minutes. We offer you a total of nine topics with more than 50 web tutorials.  
These include:

• TIA digitalization use cases

• Automatic generation of HMI visualizations with SiVArc

• Efficient teamwork with TIA Portal Multiuser

• Open communication standard OPC UA with SIMATIC S7

www.siemens.com/automation-tasks

TIA Portal Tutorial Center
The TIA Portal Tutorial Center gives you an overview of the functions and tools in the TIA Portal as well as how the configuration and 
programming tools work smoothly together. The tutorials are aimed at planners and project engineers as well as commissioning and 
service personnel. The videos mainly cover technical content and provide assistance for all stages of the machine and plant lifecycle. 
These include:

• Explanations regarding the SIMATIC S7 architecture

• Introduction to the programming languages

• Introduction to standardization with the TIA Portal libraries 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

www.siemens.com/tia-portal-tutorial-center

http://www.siemens.com/tia
http://www.siemens.com/automation-tasks
http://www.siemens.com/tia-portal-tutorial-center
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System Overview

siemens.com/wincc-v7

SCADA System 
SIMATIC WinCC
The scalable and open SCADA 
system for maximum plant 
transparency and productivity

http://www.siemens.com/WinCC


Overview

A standard, that fits
SIMATIC WinCC® is a scalable process visual-
ization system (SCADA) that is graduated by 
price and performance, with efficient func-
tions for controlling automated processes.

With SIMATIC WinCC, “perfect process  
visualization“ stands for complete  
operating and monitoring functionality 
under Windows for all industry segments – 
ranging from simple single-user systems 
through to distributed multi-user systems 
with redundant servers and the structure of 
a cross-site solution including Web clients.

One of the special features of WinCC is 
its total openness. It can be readily used  
in combination with standard and user  
programs, creating HMI solutions which 
precisely meet practical requirements.

WinCC is a modern system with an attrac-
tive user interface for use in the world of 
the office and manufacture, offering mature 
and reliable operation and efficient 
configuration.

It is scalable for simple and complex tasks. 
Together with the integrated process data-
base, WinCC represents the information 
exchange for cross-company, vertical  
integration and thanks to Plant Intelligence 
provides much more transparency in 
production.

 Video “WinCC“

https://www.youtube.com/watch?v=gMFjV3kG5H4


Content

 > Packages  > WinCC Options
 > WinCC Audit
 >  WinCC/Calendar  
Scheduler and  
Event Notifier

 > WinCC/ChangeControl
 >  WinCC/Connectivity 
Pack and  
Connectivity Station

 > WinCC/DataMonitor
 >  WinCC/
IndustrialDataBridge

 >  SIMATIC Information 
Server

 >  WinCC/ODK (Open 
Development Kit)

 >  WinCC/ 
Performance Monitor

 > WinCC/ProAgent
 >  SIMATIC Process 
Historian

 > WinCC/Redundancy
 > WinCC/Server
 > WinCC/SES
 > WinCC/TeleControl 
 > WinCC/User Archives
 > WinCC/Web Navigator
 > WinCC/WebUX

 >  Operating  
systems and  
hardware 
requirements

 > Contact > Added Value
 >  Efficiency in 
Engineering

 > Efficiency in Runtime
 > Scalability
 > Innovation
 > Openness

Added Value Packages WinCC Options Operating systems and 
hardware requirements



Added Value

The added value of  
SIMATIC SCADA systems

As the key to greater productivity,  
SIMATIC SCADA systems combine efficient 
engineering with powerful archiving and  
maximum data security. They form a solid  
foundation for efficient operational man-
agement and intelligent production 
analyses.

We offer stationary or mobile solutions to 
meet growing demands – with guaranteed 
security. To accomplish this, we draw upon 
more than 15 years of SCADA expertise in 
all industries. Whatever your requirements 
are, no matter how large or small – we 
have the right answer.

With mobile SCADA solutions, you can 
learn more anywhere and at any time – 
even with existing tablet or smartphone 
hardware. 

The use of multi-touch gestures in an 
industrial environment opens.

Special requests can be easily implemented 
thanks to the support of international stan-
dards as well as system-specific script and 
programming interfaces.

> More about Efficiency in Engineering

> More about Efficiency in Runtime

> More information > More information > More information

Added Value

Efficiency Scalabilitiy Innovation Openness

WinCC Specialists are at your service as qualified  
solution providers worldwide. These certified and  
centrally audited partners realize your individual SCADA 
project, also with distributed client-server architectures 
involving redundancy or with applications involving  
energy data management systems.

  

WinCC

?

Partner & Support
  Video “SIMATIC 

SCADA systems“

https://www.youtube.com/watch?v=Xymhe-0neN4
http://w3.siemens.com/mcms/human-machine-interface/en/visualization-software/scada/simatic-wincc/Pages/default.aspx
http://w3.siemens.com/mcms/human-machine-interface/en/visualization-software/scada/simatic-wincc/Pages/default.aspx?tabcardname=scalability
http://w3.siemens.com/mcms/human-machine-interface/en/visualization-software/scada/simatic-wincc/Pages/default.aspx?tabcardname=efficiency%20in%20runtime
http://w3.siemens.com/mcms/human-machine-interface/en/visualization-software/scada/simatic-wincc/Pages/default.aspx?tabcardname=innovation
http://w3.siemens.com/mcms/human-machine-interface/en/visualization-software/scada/simatic-wincc/Pages/default.aspx?tabcardname=openness
http://www.siemens.com/wincc-specialists
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Efficiency in Engineering

Intelligent tools for efficient  
engineering

Efficient processing of mass data

By the integration of stand-alone editors for alarm log-
ging, tag logging, text library, user administrator, user 
archive and the acoustic alarm into the Configuration  
Studio the mass data engineering got again much more 
efficient. 

It is possible to open each single editor separately which 
makes it very easy to exchange data between these edi-
tors. Of course the usual operating functionality of Excel 
is still valid. When doing project work in a team it is of 
course possible for multiple project engineers to open  
the single editors in parallel.

Resulting from the integration into the SIMATIC Manager 
of the S7-300/400 PLCs it is possible to take and align  
all variable connections as symbols and all AS messages  
automatically. In combination with the actual S7-1200 
and S7-1500 PLCs the transfer of the AS Symbols out of  
a connected PLC into the WinCC project is much faster. 
This reduces the time for the parameterizing of the com-
munication dramatically and that’s why the risk of poten-
tial faults decreases. It is also possible to automatically 
take over the AS messages of a S7-1500 into WinCC.

Support of native drivers for PROFIBUS FMS and PROFIBUS 
DP, Allen Bradley, Modicon and Mitsubishi. With the help 
of the integrated OPC-client it is also possible to connect 
to any 3rd-party system.

Tags and the optimized  
communication to the S7 PLCs

Due to the permanently increasing level of automation 
and the related complexity of the plants the cost – and 
time – pressure is increasing because of the international 
competition. One response to this pressure has to be effi-
cient engineering on the SCADA layer.

SIMATIC WinCC supports short Time-to-Market when 
building new plants and achieves a minimum of down-
time when doing plant modifications because of its effi-
cient engineering tools.



Added Value

The administration and implementation of the messages 
for the destination countries is clearly arranged and there-
fore efficient to manage. The use of UNICODE makes the 
implementation of global applications very easy. By the 
utilization of the TextLibrary it is possible to export all (or 
subsets of the) texts used in WinCC. Vice versa it is of 
course possible to import all these texts after they are 
translated to any language.

The appropriate operator language is independent regard-
less of the language of the installed operating system. 
Every operator can individually choose the language of 
the displayed texts. For example it is possible to display 
messages simultaneously using different languages when 
working in international teams.

Resulting from the integration of the cross-reference 
editor it is on one hand possible to locate very fast the 
places where a special variable is used for example in 
case of troubleshooting. On the other hand it is possi-
ble to release non used variables to align the license 
costs optimal to the actual project.

Ready for worldwide  
applications

Efficient diagnosis in the engineering 
using the cross-reference list

Fig.: Messages in different languages
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Using a configuration tool there are several setting 
options possible:

• Language- and environment settings  
(Domain / Workgroup)

• Login device: Keyboard/ Chip card Reader / other devices

That’s why it is possible for users to login and to logout 
using their native language via keyboard. But it is also 
possible to login using a chip card where name, domain 
and password is saved in encrypted form.

Integrated user administration  
including SIMATIC Logon

Using the WinCC User Administration you consistently can 
assign and check the access rights of the users regardless 
if it is a local access or if the access is web based. For up 
to 128 user groups with up to 128 single users each the 
access rights for WinCC functions can be administered.  
In total it is possible to assign 999 different permissions.

The user management with SIMATIC Logon which is a part 
of the basic system is integrated into the security system 
as well as into the user administration of Windows. There-
fore it also covers the extended FDA safety requirements.

SIMATIC Logon supports a plant wide user management 
and protects against unauthorized data manipulations.

Fig.: WinCC user administrator
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Efficient graphics system

The modern graphics system of WinCC supports the work 
of a project engineer as well by the use of standardized 
preconfigured picture components as when creating user 
definable picture components and faceplates. The use of 
these components enables the project developer to create 
his own at any time reusable company specific project  
standards which results in a much shorter Time-to- Market 
for the project.

Global settings which can be done in the graphics system 
enable the project engineers to implement once defined 
company standards in a WinCC project and to apply these 
timesaving to all picture objects which have the same  
attributes. It is also possible to export these settings and  
to import them again to any other WinCC project. 

On one hand this possibility supports the in-house stan-
dardizing in an efficient way and on the other hand it pro-
vides the opportunity that several project engineers can 
work on huge applications simultaneously in accordance 
with the company standards. When creating images it is 
of course possible to do Direct2D (soft shadows) and to 
integrate SVG – files.

Instead of using discrete colors the color palette is work-
ing with color indexes. This enables the user to realize 
customer-specific designs in a very simple way. If for 
example a customer wants to change the color from red 
to orange he only has to assign the color orange to the 
index for the color red. While changing this, the color of 
all red objects having the same index changes to orange.

Applying modular design makes it simple to create and  
to centrally manage custom specific faceplates. Changes 
are automatically applied to all points where the faceplate 
is utilized. For example efficient operation is possible by 
the use of application specific menus and toolbars. It is 
possible as usual in Windows to either fix them or to leave 
them movable. 
The project engineers are able to adapt the Menus and 
Toolbars to their individual needs by using the integrated 
‘Menus and Toolbars Editor‘. This makes configuring even 
more efficient.

Libraries and wizards accelerate make the setup of  
projects easier. Therefore they reduce the error rate 
dramatically.
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Efficiency in Runtime

WinCC allows you to implement display languages in a 
simple and cost-effective manner. Thanks to UNICODE 
support, the display language can be changed at any time 
during operation. This is independent of the language set 
in the operating system. This means that it is possible to 
display multiple languages parallel to each other, such  
as message texts in European and Asian languages. 

This makes commissioning considerably easier in inter-
national teams. 

The WinCC/WebUX option is supplied with the WinCC sys-
tem and differentiates between Monitoring and Operate 
clients. With the installation of the basic system as WinCC/
WebUX server, ONE Monitor client is available at no addi-
tional cost.   

This allows you to display your plant information using 
smartphones, tablets, PCs and other mobile devices that 
support a HTML 5 capable browser. No installation is 
required on the client side in order, for example, to dis-
play important product data for quality assurance or key 
production figures for the management. 

Additional Monitoring and Operate clients for remote 
operation can be added at any time by means of appro-
priate licensing. 

Efficient operations management – 
the WinCC Runtime functionality

Ready for worldwide use Integrated Monitoring Client 

Manufacturing processes are becoming more and more 
complex against a background of ever increasing quality 
requirements coupled with fast product changes and fre-
quent modifications. To ensure the highest possible pro-
ductivity at the same time, it has to be possible to make 
prompt, target-oriented decisions regarding process opti-
mization at all levels of a company. This requires an inte-
grated flow of information across all operating levels and 
locations. 

SIMATIC WinCC provides you with high transparency and 
the basis for process optimization.  The intelligent use of 
information improves the processes in the company for  
a fast return on investment. This reduces costs, avoids 
waste, improves the utilization of production facilities and 
ultimately guarantees better efficiency and cost effective-
ness for the company. 

PLANT OVERVIEW Production View

700
400

01
COMPONENT

14
PLANT

03
STATION

05
STATION

04
STATION

07
STATION

08
COMPONENT

11
PLANT

12
STATION

13

06
PLANT

09
STATION

10
DEPOSIT

500
400

900
1500

800
400

500
1500

STATUS REPORTS USER

02
STATION

06 / Plant: Shutdown complete John Regular

03 / Station: Unexpected temperature rise Plant Supervisor

03 / Station: Unexpected performance rise   

650
1300

800
400

600
1500

24 hr 

0

12

618
History

VIEW

EDIT

EDIT

EDIT

EDIT

EDIT EDIT

VIEW

VIEW

VIEW

CURRENTLY

ACTUAL / DEBIT 

432/276

 15:00

IN VIEW

STATION

PLANT

SELECT PLANT

UNIT

Production Details

0114
TREND Average 30s

1000

800

600

400

200

100

23.10.2012

12:50:00

23.10.2012

13:00:00

23.10.2012

13:10:00

23.10.2012

13:20:00

23.10.2012

13:30:00

23.10.2012

13:40:00

23.10.2012

13:50:00

INTTAGS: Motor 1 Ventil 1

Value

UNIT 1 Overview Production INTTAGS: Motor 1 Ventil 1

Timestamp Actual Value

0 200 400 600 800 1000

41205.

4788234259

41205.

4718789815

41205.

464934537

41205.

4579900926

AVERAGE

EstimationSTATE

-100 

100 

300 

500  900

 1100

 1300

 1500

700

600



Added Value

Efficient controls are integrated into WinCC process  
pictures for the display of current or historical data.  
 Process values can be displayed as a table or analyzed 
using a trend display. 

The display is either predefined or can be adjusted indi-
vidually by the operator, if authorized. Numerous means 
of representation guarantee the best possible overview.

The freely configurable toolbar functions also provide  
the option of integrating project-specific functions.

f(x) trends, e.g. pressure/temperature, can also be  
displayed in addition to the time- and value-based 
representation.

High-performance data archiving Efficient analysis of process values 
(Trends)

Historical process information is stored in WinCC process 
value archives.  Process values and messages are archived 
in the integrated, high-performance MS SQL server data-
base, and memory requirements are optimized through 
powerful, loss-free compression functions. 

You can configure 512 archive tags in the WinCC basic 
system. In the final configuration, this archiving can be 
extended to up to 80,000 variables per server by using 
power packs. The frequency of the archiving (cyclic, 
event-driven) can be configured for each value and, if 
required, additional compression can be configured with 
the swinging door algorithm. 

In addition to automatic archiving, with the correspond-
ing authorization, it is possible to insert values manually 
into the archive or to change archive values. 

This is required for laboratory values, for example, in 
some industries. For reasons of traceability, such values 
are marked as “manually changed” and the process docu-
mented by an operation message. 

To reduce the amount of data for long-term archiving, 
data can be further compressed. For this purpose, the 
maximum, minimum or (weighted) mean, the total or  
the difference are calculated for configurable time periods 
(such as day, month, year) and stored in compressed 
archives. 

In addition to the archiving on a WinCC server, central, 
optionally redundant long-term archiving can also be 
implemented using the SIMATIC Process Historian option. 



Added Value

In combination with the Ruler Controls, there is also the 
option of performing statistical calculations online with-
out the need for programming. The relevant statistics – 
maximum and minimum value, average value, (weighted) 
mean, integral and total – are displayed without delay for 
a time range selected in the Trend Control. The messages are displayed on the screen via the freely 

configurable WinCC Alarm Control. Here, the display of 
the message information can be adapted precisely to the 
requirements of the operator. The settings made can be 
saved in user-specific or global templates. 

WinCC Alarm Control for the display of current/historical 
messages based on the contents of the individual mes-
sage blocks can be filtered, selected and sorted, for exam-
ple chronologically, by priority or by fault location, in the 
display. The contents can then be exported directly as  
CSV file or printed out as report. A freely definable toolbar 
function also offers a maximum degree of flexibility. For 
examples, project-specific functions can be integrated.  
To maintain an overview when there is a large numbers  
of incoming messages, unimportant operating messages 

Efficient analysis of messages

can be suppressed from the screen display via an alarm 
hiding function. The hidden messages are then archived 
in the background.

Numerous integrated statistics functions allow a com- 
prehensive analysis of process states. The message hit list 
shows how long certain messages were pending on aver-
age and in total (message duration) and similarly the aver-
age and the total acknowledgment time. Of course, the 
messages can be filtered here by relevant events, message 
locations and time intervals. This indicates quickly where 
critical points and bottlenecks in the production are 
located. To sort the messages in the message display  
for an evaluation, you can simply select the column  
heading and the required sorting criterion (for example, 
“Frequency, descending”).



Weak points in production processes can be located and 
potential for optimization identified using the WinCC/Per-
formance Monitor. Plant-specific key performance indica-
tors (KPIs), such as overall equipment efficiency (OEE),  
are calculated and analyzed directly in the WinCC system. 
Conclusions about efficiency can be derived by comparing 
the time states of machinery or equipment in the Gantt 
chart. Key performance indicators such as day, shift or 
product can be compared directly with each other using 
Performance Control. Additional associations, such as 
quality per supplier, can be shown by linking context val-
ues. Target-group-oriented analysis reports can also be 
created Web-based with the SIMATIC Information Server.

With WinCC/User Archives, related data, such as machine 
parameter assignments or production data, is grouped 
together in user archives. Such archives are characterized 
by a fixed data structure that is predefined during the 
configuration.

The individual parameters can be specified by the opera-
tor in runtime or directly exchanged with the automation 
partners (for example, a SIMATIC S7 controller). The data 
records can be further processed with other tools (such  
as MS Excel) via the import/export function.

Efficient Web-based reporting Efficient analyses of production  
processes

Efficient management of data records 
(recipes)

The SIMATIC Information Server can be used to create  
target-group-oriented reports and evaluations using  
historical WinCC and Process Historian data on the basis 
of Microsoft Reporting Services.

The reports created are available as Web-based dash-
boards or on tablets and can be automatically forwarded 
as emails. Through add-ins, transparent data access is  
also possible with MS Word, MS Excel or MS PowerPoint.

  Video “WinCC/PerformanceMonitor“

  Video “Process Historian“

  Video “Information Server“

Added Value

https://www.youtube.com/watch?v=hDSmNkZd1qo
https://www.youtube.com/watch?v=hDSmNkZd1qo
https://www.youtube.com/watch?v=MBtOxnrFlA0&feature=youtu.be


Increasing energy costs worldwide are becoming a big 
challenge for companies – and thus also a key factor in  
a company’s success and in safeguarding jobs. 
Rising energy prices and an increased public awareness  
of environmental issues mean that effective energy man-
agement is contributing more and more to the success of 
companies and thus to safeguarding the continued exis-
tence of companies. 
Improved energy controlling and the reduction of power 
costs are among the main challenges faced by companies. 
Industrial companies continue to battle against a lack of 
transparency in their infrastructure processes, against 
changing cost centers, heterogeneous system environ-
ments and a costly power reporting.

The two calendar options expand WinCC with calendar-
based functionality.  Joint calendar control is hereby 
used to plan times or validity periods. 

Time-linked actions can be triggered with the WinCC/
Calendar Scheduler.

The WinCC/EventNotifier sends notifications depending 
on the occurrence of certain events in the WinCC  
message system.

WinCC/ProAgent allows targeted process diagnostics  
for machinery and plants. Through the integration in 
the world of SIMATIC process diagnostics, ProAgent 
offers an integrated solution based on STEP 7,  
engineering tools and S7 controllers.

Traceability in production processes Efficient energy data management Calendar- and event-based  
functionality

Efficient process diagnostics

WinCC/Audit is used to provide end-to-end traceability  
of operator activities in operation and to record project 
changes during the engineering phase by means of proj-
ect versioning and audit trails. All change data is recorded 
in a tamper-proof database - the so-called Audit Trail – 
and displayed using the Audit Viewer. The use of WinCC/
Audit helps machine manufacturers and plant operators 
to simultaneously reduce the expenditure for fulfilling  
the requirements according to 21 CFF Part 11 and  
EU 178/2002.

  Video “SIMATIC B.Data“

Added Value

http://www.automation.siemens.com/salesmaterial-as/interactive-manuals/simatic-b-data/enUS/start.swf


Added Value

Scalability

Depending on requirements, a WinCC single-user system 
can be expanded into a high-performance client/server 
system. In this way, several coordinated operator control 
and monitoring stations can be operated together with 
networked automation systems.

The WinCC/Redundancy option gives the user the opportu-
nity to operate two linked WinCC server PCs in parallel, in 
order to monitor each other. On the failure of one of the 
servers, the second server assumes control of the entire 
system. When the failed server resumes operation, the 
contents of all message and process value archives are 
copied back to the restored server. The automatic switch 
to the redundancy partner within the framework of 
WinCC/Redundancy is not only carried out in the case of  
a failed server, but also in the case of a faulty process 
communication. 

From single-user system to web- 
based solution for all technologies 
and industries

Client-server solutions Redundant server solutions

To be able to meet growing requirements, the visualiza-
tion must be expandable at any time without causing 
technology incompatibilities or requiring completely 
new configurations. 

Investment protection is a top priority. 

SIMATIC WinCC provides the required integrated scala-
bility, from the small single-user solution to the client/
server solution and operator stations on the web.  
Redundancy solutions for highest availability and 
 security can be built up as well.

In addition to scalable configurations, WinCC options 
and AddOns offer customer-fit extensions for techno-
logical and industry specific solutions.
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Web solutions

WinCC/WebUX offers flexible operator control and moni-
toring of plant processes via the Internet or an intranet, 
especially using mobile devices (tablet PCs or smart-
phones). All devices with HTML5-capable browser are 
supported.

WinCC/Web Navigator allows integrated operator control 
and monitoring of plants via the Internet or intranet with-
out having to make changes to the WinCC project. Thin 
client solutions support the use of PCs and even rugged 
on-site devices and mobile PDAs.
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Web-based reporting Central archive server solution

SIMATIC Information Server supports the creation of  
target group-oriented reports and analyses of historical 
WinCC data on the basis of Microsoft Reporting Services.

The reports created are always available on Web-based 
user interfaces and can be automatically distributed by 
email. 

Transparent data access is allso provided by MS Word,  
MS Excel and MS Powerpoint. 

SIMATIC Process Historian provides high-performance 
long-term archiving functionality for perfect integration 
into the SCADA System WinCC: Process data and mes-
sages can be written to central archives in real-time 
mode, without additional engineering efforts. 

The data in a central long term archive can be  provided 
by several WinCC systems. You can use standard WinCC 
functions to analyze them or employ the SIMATIC Infor-
mation Server for further processing. 

SIMATIC Process Historian replaces the previous WinCC/
CentralArchiveServer option. 

SIMATIC Information Server supports the creation of target 
group-oriented reports and analyses of historical WinCC 
data on the basis of Microsoft Reporting Services. The 
reports created are always available on Web-based user 
interfaces and can be automatically distributed by email.

Transparent data access is also provided by MS Word,  
MS Excel and MS Powerpoint.
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Performance Analysis Solutions for all industries  
and technologies

Using the WinCC/PerformanceMonitor shows weak points 
of production and to suitable optimization potential can 
be derived.  
Therefore, plant-specific key figures (KPIs) for individual 
devices, machines, or entire production lines can be cal-
culated and analyzed in machine or line-oriented produc-
tion plants.  
The required formulas e.g. for calculate of OEE, are con-
figurated in WinCC and directly linked to process values.  
It is possible to link KPIs with context data to get further 
correlations e.g. quality for each supplier.  
WinCC provides table-, performance- and gantt controls  
to analize performance indicators-  also using WinCC/ 
WebNavigator. Target group-oriented reports and analy-
ses are always available on Web-based user interfaces 
using the SIMATIC Information Server option.

WinCC/SES manages and controls sequential processes 
e.g. for dosing, mixing, material handling.

Distributed over one or multiple production units, pro-
duction processes are organized in a simple and flexibly 
manner. The combination of automated processes and 
manual adaptions simplifies the handling of natural 
resources (e.g. in food and beverage industries). 

 The WinCC/Telecontrol system is the cost-effective  
solution for monitoring and controlling widely distributed 
processes in systems of any size and in any industry. 

Therefore, it flexibly integrates remote terminal units  
into the central process visualization system of the entire 
plant via a WAN (Wide Area Network). It supports the 
three most important international telecontrol protocols  
IEC 60870-5 101/104, DNP V3 (serial or TCP/IP), and 
SINAUT ST7 (serial or TCP/IP). 

The diverse network topologies and transmission proto-
cols allow a flexible configuration according to individual 
requirements.
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Related products
Software for Energy Management

SIMATIC B.Data

allows users to implement an optimized and cost-
effective operational energy management in the 
areas of controlling, planning and energy 
procurement.

SIMATIC B.Data*/Energy Manager PRO

SIMATIC powerrate

ensures transparency in energy consumption from 
the infeed to the load. Energy data is continously 
collected, achived and further processed.

> More about SIMATIC B.Data

>    More about SIMATIC B.Data/
     Energy Manager PRO*

> More about SIMATIC powerrate 

Added Value

*  SIMATIC Energy Manager PRO is the proposed  
successor of SIMATIC B.Data

http://w3.siemens.com/mcms/automation-software/en/energy-management-sw/simatic-b-data/Pages/default.aspx
http://w3.siemens.com/mcms/automation-software/en/energy-management-sw/simatic-powerrate/Pages/default.aspx
http://uds.ak.o.brightcove.com/1813624294001/1813624294001_4800396458001_cq5-4823657042528635260bdata-v60-en.mp4?pubId=1813624294001&videoId=4800403768001


Innovation

SIMATIC Information Server is a comprehensive reporting 
system for analyzing archived data. Based on the Micro-
soft SQL Server Reporting Services it provides interactive 
reporting services in the form of Web-based analyses. The 
reports created are always available on Web-based user 
interfaces and can be automatically distributed by email. 
Transparent data access is also provided by MS Word,  
MS Excel and MS PowerPoint using Add-ins.

Consistent reporting system for:
• SIMATIC Process Historian 2014
• WinCC ( V7.0 SP3 or higher) and WinCC/ 

PerformanceMonitor option package
• WinCC (TIA Portal) RT Professional (V13 SP1 or higher)
• PCS7 ( V8.0 or higher) and SIMATIC Batch
Transparency at any time in any place from process  
to management level.

State-of-the-art, innovative operational concepts with 
multi-touch gestures are rapidly gaining significance in 
the industrial environment. The gestures that users know 
from consumer devices are particularly useful for more 
simple and intuitive operation of complex production 
plants.

SIMATIC WinCC V7.3 accordingly supports two-finger 
operation. You can implement functionality such as zoom 
or wiping, for example, for screen navigation and pan-
ning. SIMATIC HMI WinCC V7.2 also supports two-hand 
operation that can be used, for example, as enable  
function for setpoint input.

Future proof due to innovative  
solutions

Web-based reporting system  
for historical plant data

Intuitive operation with 2-finger 
multi-touch gestures

Mobile SCADA providing exactly the information  
the user needs

The WinCC/WebUX takes account of the increasing calls 
of the users to mobile view and control processes via  
the internet and the intranet. 
Using such a flexible access to gain plant data extends 
the classical control room as it is today. Depending on 
the application area it is possible to monitor only as well 
as to control the process.

Because of the individual access to process data using 
the mobile Scada the user will be informed 
• fast
• cheap
• target oriented
about all the data of a plant which is important for him.

  Video “WinCC/WebUX V7.3“   Video “SIMATIC Information Server”   Video “SIMATIC IPC Multi-touch“

Added Value

https://www.youtube.com/watch?v=7zt_lYT7_Zw&feature=youtu.be
https://www.youtube.com/watch?v=JeehHrN_wRA
https://www.youtube.com/watch?v=2uM6hRkAnC0&list=PLw7lLwXw4H53UHYqYJo8P3QAjYTkgjcGk&index=8


Openness

Extensions of the runtime system 

Using WinCC it is possible to realize connections and 
dynamic sequences without programming only by the use 
of standard dialogues. To realize more complex functions 
it is possible at any time to write scripts using VB or  
ANSI-C. Examples for such scripts are the conversion of 
values or the automatic start of reports or of individual 
messages. 

When programming VB scripts you are supported by the 
use of a proprietary, comfortable editor with debugging 
support.

When using scripts you have full access to the properties 
of all WinCC graphical objects and to the controls as well 
as to the object model of WinCC and the applications of 
other manufacturers.

Using standards  
for easy integration

Individual adjustments

SIMATIC WinCC all times stands for a high level of  
openness and integration capability because it is conse-
quently based on standard technologies and software 
tools. 
Starting with its first version SIMATIC WinCC relies on 
the market leader in the operating system area. It 
doesn’t matter if you use Microsoft Windows 2008/2012 
Server, Windows 7 or Windows 8.1 you can track 
updates in the operating system. At last for you that 
offers additionally investment security. 
The powerful SQL Server 2008 R2 SP1 (32 Bit) is inte-
grated within the WinCC basis system. Using open inter-
faces helps you to automatize the engineering as well  
as the runtime and the access to archive data.

Enhancements of the engineering system

Furthermore the comfortable configuration tool Visual 
Basic for Applications (VBA) is integrated in the WinCC 
Graphics Designer. This is very helpful for writing custom 
specific enhancements including debugging. By using this 
functionality engineers and users can make full use of 
their Visual Basic-knowledge. VBA can be used to realize 
own standards, to handle recurring tasks, to create menu 
entries or configuration dialogues. This saves time and 
money.

Added Value



The WinCC/IndustrialDataBridge is using standard inter-
faces (e.g. OPC,OLE-DB,  SQL) to connect the automation 
level with the IT – world and to guarantee a bidirectional 
information flow. 
Using the WinCC/IndustrialDataBridge (short IDB) it is pos-
sible to exchange data between systems of different pro-
ducers without having deep knowledge about their inter-
faces and the associated data formats. Using the efficient 
configuration tool of the IDB it is possible to configure the 
various data connections which avoids mistakes. 
It is possible to apply the WinCC/IndustrialDataBridge as  
a system service. It is possible to use this stand-alone  
solution independent of the SCADA system. 
By choosing the integration into the WinCC system the 
transparent user administration in combination with the 
WinCC/IDB control guarantees the monitoring of the data 
connection to the WinCC screens also via Web.

Open programming interfaces Bidirectional information flow  
from shop-floor to top-floor 

The WinCC function modules are exposed using inter-
faces which allow access to the data and the functions of 
the configuration environment as well as to the runtime 
system itself. 

Using this interface you are able to apply WinCC-project-
ing functionality and runtime functions to your scripts or 
to write autonomous applications with direct access to 
the WinCC system.
The WinCC/Open Development Kit (ODK) describes the 
open interfaces which are provided as C-Application Pro-
gramming Interface (C-API). Starting with WinCC V7.2 the 
ancient option WinCC/IndustrialX is included in ODK.
Also numerous additional ActiveX-elements and a config-
uration toolset containing Visual Basic Templates is 
included for the simple creation of ActiveX-Controls. The 
development of individual controls supports the creation 
of industry- and technological functions as protected and 
standardized modules. This reusable controls shorten your 
time-to-market and protect your know-how.
Besides of the integration of ActiveX-Controls using  
the WinCC Media Control (.NET Framework 3.5 & 4.0  
Container) the integration of user specific XAML and  
.NET controls is also supported.

  Video “WinCC/IndustrialDataBridge”

Added Value

https://www.youtube.com/watch?v=fdVc-EElXuI


The Connectivity options open a series of additional  
communication possibilities using WinCC OLE-DB Provider 
OPC.

The option package WinCC/Connectivity Pack every time  
is used in combination with a WinCC system.  
The WinCC/ConnectivityStation  is used with autarchic  
PCs (without WinCC installation).

• WinCC OLE-DB Provider  
For direct access to process values and message 
archives. It is possible to write individual applications 
using WinCC OLE DB to get access to the databases.  
For the communication with the WinCC OLE DB-Provider 
ADO DB /ADO.NET can be used within applications, 
which for example are build using Visual Basic, VBScript 
or VB.NET

• OPC XML DA 1.01-Client  
Web based and platform-independent access to process 
values for example to integrate third-party PLCs  
or -systems

Cross vendor communication using 
OPC (OLE for Process Control) 

WinCC/Connectivity Pack  
and WinCC/Connectivity Station

OPC is used as a communication standard for a secure 
and authentic data exchange between applications 
within the industrial automation environment. It 
describes a series of specifications which are used manu-
facturer independent as an interface between different 
clients and servers as well as between different servers 
only. These include amongst other topics direct access 
to real-time data, the monitoring of messages and 
events as well as access to historical data.
Originally the OPC standard only was available on Win-
dows operating systems. This standard was developed 
from OLE (Object linking and embedding) for Process 
Control. The new OPC UA spec which was introduced in 
2009 describes a real universal connection. This stan-
dard is based on a secure, simple technology-indepen-
dent platform which is future-assured and scalable as 
well as expandable for all challenges of the different 
company levels.
SIMATIC WinCC offers by default: an OPC DA-client 
2.05a/V3.0 providing access to process data e.g. to  
connect the system to third-party PLCs or -systems.

• OPC UA Client 1.02  
Access to process data according to the OPC Unified-
Architecture specification

• OPC HDA 1.20-Server (Historical Data Access)  
Access to historical data of WinCC for example to share 
the data for your own proprietary reporting system

• OPC A&E 1.10-Server  
Forwarding of WinCC process alarms and events

• OPC XML DA 1.0-Server  
Platform independent data exchange via web between 
WinCC and Office-applications, ERP/PPS-systems  
(e.g. SAP/R3) or Business-to-Business-portals

• OPC UA Server 1.02  
Transfer of process values, archive data and messages 
of WinCC under the terms of the OPC UA specification 
1.02. In addition to that a separate licensed OPC UA 
Server for the connection to the SIMATIC Process  
Historian is available

Added Value



WinCC complete  
package/runtime package

SIMATIC SCADA and 
SIMATIC IPCs

The WinCC system software is available in two basic 
variants:

• WinCC complete package  
(RC: license for runtime and configuring)

• WinCC runtime package  
(RT: runtime license)

The SIMATIC SCADA systems and SIMATIC Industrial PCs 
together form a high-performance and reliable platform 
for the acquisition, evaluation, and visualization of data. 
The harmonized and certified total package of hardware 
and software offers the highest quality in all industries.

Packages

Both packages are available with 128, 512, 2k, 8k,  
64k, 100k, 150k or 256k PowerTags. PowerPacks allow  
an increase in the number of usable Power-Tags. Thus, 
WinCC also grows when your application grows. 

Only process tags that are connected to the controller or 
other data sources via a WinCC communication channel 
are designated as PowerTags. The WinCC basic system 
already allows up to 512 archive tags to be configured,  
as WinCC includes a Microsoft SQL Server licenses. In  
the final capacity stage, Archive PowerPacks enable the 
expansion to up 80,000 tags each server.

SIMATIC WinCC offers a configuration user interface in 
English, German, French, Spanish, and Italian, Chinese 
(simplified and traditional), Japanese and Korean. 

There are special Asian WinCC versions available which 
are additionally protected by a hardware dongle. Soft-
ware packaging and licenses are following the same  
scaling as the European version.

  More information

http://w3.siemens.com/mcms/pc-based-automation/en/simatic-scada-ipcs/Pages/Default.aspx


Update Service and Special licenses Virtualization

WinCC Comprehensive Support  
(Software Update Service)

The Software-Update Service for WinCC comprises the 
Updates and Upgrades of the WinCC basic software as 
well as the WinCC Options. Therefor and because of  
additional information included in each delivery we  
called it WinCC/Comprehensive Support.

  More about Update Service   More about Siemens Automation 
cooperates with education

Trainer Packages

In the context of the program Siemens Cooperates with 
Education you can purchase trainer packages at special 
conditions.

To reduce the administration and mainte-
nance effort, the automation world is 
turning increasingly to virtualization and 
the opportunity it provides to decouple 
applications from hardware. This enables 
centralized management and further sim-
plifies backing up and restoring the system 
environment. Client environments can be 
installed once and distributed among one 
or two virtualization servers using virtual 
sessions (instances).

Packages

http://w3.siemens.com/mcms/topics/en/simatic/licenses/software-update-service/Pages/Default.aspx
http://w3.siemens.com/mcms/sce/en/Pages/default.aspx


Expanding your  
WinCC basic system

Get SIMATIC WinCC tailored to your requirements. WinCC 
options are evidence of the modular expandability and the 
universal application of WinCC which is the core for a 
whole range of different applications. The WinCC option 
packages are produced in the context of WinCC develop-
ment. As the basic WinCC software they are supported by 
the technical advisory service and the central hotline.

SIMATIC WinCC Options

  Video “SIMATIC WinCC V7.4 –  
Presentation at Hanover fair 2016”

https://www.youtube.com/watch?v=_8OE4ZlkrN8


Tracing operator inputs 
and project changes

WinCC/Audit is for monitoring changes in operator activi-
ties in runtime operation as well as for recording project 
changes at the engineering stage. The system records all 
the change data in a secure database known as the Audit 
Trail. You can view the Audit Trail using the Audit Viewer.

This means that using WinCC/Audit provides continuous 
traceability of both operator activities and changes to 
projects and, at the same time, also helps machine tool 
builders and plant operators to reduce the amount of 
engineering time and effort involved in complying with 
the requirements of 21 CFR Part 11 and EU 178/2002.  
The engineering measures that are necessary for making 
validation easier are documented in a white paper.

• Reliable recording of operator actions and project  
changesin Audit Trails

• Project versioning and document control  
• Compliant with the requirements of the FDA  

(Food and Drug Administration)
• Reduced engineering effort to comply with  

21 CFR Part 11 & EU 178/200 

Monitoring runtime operation

In runtime operation the system records the following  
in the audit trail: 

• Operating activities carried out, 
• Activities within the scope of central user management 

using SIMATIC Logon  
• Starting and changing recipes 

Apart from this, plant operators can individually record 
specific events by means of an audit entry function:

• Operation of pushbuttons and sliders  
• Record Pressing of a key

Audit Trail database and Audit Viewer

The Audit Trail database stores all the change data that  
is subject to document control; this includes user actions, 
confi guration changes and other changes. Components 
of Audit Trails include:

• Date and time of the change 
• Droject ID, PC and database name  
• Old value and the new one 
• User name 
• Event/function 
• Comment/reason for change 

The system visualizes the Audit Trail data by means of the 
Audit Viewer. Operators use filters to selectively set the 
desired view of the Audit Trail data and they can export 
this data to an Excel file. The Audit Trail data is stored 
securely on a tamper-proof basis and this means that  
you cannot change or delete it. 

This means that WinCC/Audit meets the FDA requirements 
of 21 CFR Part 11 in this respect too.

SIMATIC WinCC/Audit

Description Benefits

Design and functions 



Tracking project changes

Monitoring project changes is possible with WinCC/Audit 
and with the option package WinCC/ChangeControl as 
well. In this connection, WinCC differentiates between 
configuration changes that affect the WinCC database, 
e.g. changes in Tag Management or creating a user group 
and configuration changes that are limited to changes to 
files, what is known as document control. Document con-
trol involves process pictures, scripts and log layouts and 
customer-specific documents. This means that WinCC/
Audit can monitor all these documents or files for 
changes, create intermediate versions or retrieve them 
using a rollback function. The entire monitoring process 
can be activated very easily and conveniently. This means 
that in the case of plant standstills, for example, plant 
engineers and operators can quickly and easily compre-
hend the changes that have been made to the plant. This 
supports trouble-shooting and reduces plant downtimes.

Design and functions 

Using a project versioning tool 

• WinCC projects can be archived, restored and deleted  
• WinCC data including the project database, project files 

(e.g. screens, reports, scripts) and user documents can 
be archived

• Activities of the project versioning tool can be recorded 
  

In this way all changes made to a plant beginning from 
the production start and continuing throughout the entire 
life cycle can be recorded and – using defined versions – 
be documented.



Working with  
calendar functions

The Calendar Options supplement WinCC with calendar-
based functions. A common calendar control supports the 
planning of schedules and of validity periods. You can use 
the Calendar Scheduler to trigger time-based actions; 
theEvent Notifier sends messages depending on specific 
events in the WinCC message system.

• Simple and reliable scheduling of events and actions
• User-friendly HMI in the style of Microsoft Office
• Easy to send important messages to a defined group  

of people at a defined time by email or text message
• Guaranteed comprehensibility: 
• Events and actions are logged and displayed in the 

WinCC alarm logging

WinCC/Calender Schedular

The Calendar Scheduler supplements WinCC by a calendar-
based HMI in the style of Microsoft Office. It includes  
editors with which events and associated actions can be 
configured and managed. The planned events and actions 
can be connected directly to WinCC tags or global scripts. 
In order to control the plant process, several calendars, 
events and associated actions can be created, filtered, 
edited and managed. For example, the action editor can 
be used to execute program scripts. The editor supports 
events and interruptions which occur regularly, e.g.  
holidays or maintenance work.

Multi-level user privileges protect the scheduling from 
unauthorized access. The message system logs and dis-
plays every action carried out. This guarantees compre-
hensibility of the corresponding events.

WinCC/Calendar Scheduler and WinCC/Event Notifier

Description

Benefits

Design and functions 



WinCC/Event Notifier

You can use the Event Notifier to set which people in a 
defined time period are notified about specific events.  
The events are associated with messages in the WinCC 
message system. Contacts can even be selected as poten-
tial messaging targets from the WinCC user administration 
during runtime. The messages can be sent via email or  
via a provider gateway as text message(SMS) to a mobile 
phone.

If multiple groups of people are defined for messaging in 
the same time frame, different escalation times (i.e. delay 
time before messaging) can be realized. This means that 
group 2 is only messaged if none of the people “on-site”  
or the previously messaged people have responded within 
the configured escalation time. When someone reacts to 
the triggering event, allpersons messaged receive an 
acknowledgment.

Calendar Control is configured in the Graphics Designer 
and can be dynamized with all WinCC standard mecha-
nisms such as tag connection, VBS, C, direct connections 
or dynamic dialogs in WinCC.

Design and functions



Tracing of project changes

Monitoring project changes is possible with WinCC/Audit 
and with the option package WinCC/ChangeControl as 
well. In this connection, WinCC differentiates between 
configuration changes that affect the WinCC database, 
e.g. changes in Tag Management or creating a user group 
and configuration changes that are limited to changes to 
files, what is known as document control. Document con-
trol involves process pictures, scripts and log layouts and 
customer-specific documents. This means that WinCC/
Change Control can monitor all these documents or files 
for changes, create intermediate versions or retrieve them 
using a rollback function. The entire monitoring process 
can be activated very easily and conveniently. This means 
that in the case of plant standstills, for example, plant 
engineers and operators can quickly and easily compre-
hend the changes that have been made to the plant. This 
supports trouble-shooting and reduces plant downtimes.

Using a project versioning tool

• WinCC projects can be archived, restored and deleted 
• WinCC data including the project database, project files 

(e.g. screens, reports, scripts) and user documents can 
be archived 

• Activities of the project versioning tool can be recorded 

In this way all changes made to a plant beginning from 
the production start and continuing throughout the entire 
life cycle can be recorded and – using defined versions – 
be documented.

WinCC/ChangeControl

Description Design and functions Benefits

• Project versioning and document control 
• Compliant with the requirements of the Food  

and Drug Administration (FDA) 
• Reduced engineering effort to comply with  

21 CFR Part 11 & EU 178/200 



Access to WinCC using  
OPC & WinCC OLE-DB

In WinCC, non-proprietary communication in the field  
of automation has always been very important.

WinCC has as standard an integrated OPC DA 3.0 server 
(Data Access) that gives you access to all the online values 
in the system and, on the other hand, can as a client read 
data from another application - across the Web too. The 
WinCC/ Connectivity Pack offers additional options.

This means that the system can transfer pre-processed 
process and production data to higher level systems for 
information conditioning (e.g. Manufacturing Execution 
Systems, Enterprise Resource Planning systems or office 
packages, e.g. Microsoft Excel, Microsoft Access, etc.).

Access to messages and historical data  
via OP /WinCC OLE-DB

The WinCC/Connectivity Pack includes the OPC HDA 1.1 
(Historical Data Access) and OPC A&E 1.0 (Alarm & Events) 
servers for accessing historical data of the WinCC archive 
system or for transferring/acknowledging messages. As  
an OPC XML DA 1.0 server, WinCC can even send data on  
a cross-platform basis across the Web to PPS/MES systems; 
in the opposite direction, it can take OPC XML DA client 
order or recipe data. As an HDA server WinCC makes avail-
able historical data from the WinCC archive system to 
other applications. The OPC client (e.g. a reporting tool) 
can specify the start and end times of a time interval and 
thus selectively request the data to be transferred. Apart 
from this, the client can request already conditioned data 
from the HDA server, i.e. actively trigger data compression 
before the data is transferred. The OPC HDA server can 
also be used in redundant configurations.

WinCC/Connectivity Pack and Connectivity Station

Description Design and functions Benefits

• Simple IT and business integration by means  
of standard interface

• Access to online and historical data from any  
computers you like via standard interfaces.  
(OPC XML DA, OPC HDA, OPC A&E, WinCC OLE-DB) 

• Further processing or analysis of data using separate 
tools is possible 



In OPC A&E, the system displays a WinCC message as an 
alarm and, together with all the ancillary process values, 
passes it on to any subscribers on the production or com-
pany management levels. Due to the filter mechanisms 
and subscriptions, the system only transfers selected, 
changed data. It is, of course, also possible to carry out 
acknowledgement at the MES or ERP level. 

Design and functions 
WinCC/ConnectivityStation

If process visualization is not needed at a station, you can 
use this WinCC option package to confi gure any Windows 
computer you like as a connectivity station with access  
to WinCC via OPC and WinCC OLE-DB without needing a 
WinCC installation to do so.

 
Client Access Licenses (CAL)

To directly access current WinCC data via OPC DA, you do 
not need a separate license. You always need WinCC/CAL 
whenever you want to access WinCC data across the inter-
faces of the options WinCC/Connectivity Pack and WinCC/
IndustrialDataBridge from any computer which has not 
installed (and licensed) neither the basic WinCC system 
nor a WinCC option.

If desired, the WinCC/CAL pro Processor License even pro-
vides access for all the computers in your confi guration  
to the interfaces of the Connectivity Pack or allows them 
to use the IndustrialDataBridge.

Online data access 
(tags) 3rd party data base access

Online data access 
(historical data)

Online alarms
(Forward / Acknowledge)

* 3rd Party OPC Client

MS SQL ServerSIMATIC WinCC

ERPMES MES

OPC UA Server (DA, A&E, HDA)

OPC UA DA
(Client)

OPC XML DA
(Server/Client)

OPC HAD
(Server)

* * *

WinCC OLE-DBOPC A&E
(Server)

OPC A&E 
(historical)

(Server)

WinCC/ConnectivityPack
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VB (.NET), C# 
VB Script, VBA

The WinCC OLE-DB Provider makes it possible to directly 
access the archive data that WinCC stored in the Microsoft 
SQL Server database (alarms, process values, user data).  
In this connection, you can even use statistic functions. 
From a WinCC multi-client, a transparent process data 
access via the OLE DB is now also possible to redundant 
WinCC systems and distributed configurations with central 
archive server. For the addressing, only the symbolic com-
puter name is needed.

Fig.: WinCC/ConnectivityPack: 
Access to WinCC via OPC & 
WinCC OLE-DB



Visualizing processes, analyzing  
and distributing data

The WinCC/DataMonitor is an important component for 
plant intelligence applications in combination with the 
process visualization system WinCC.

The DataMonitor is used for the display, analysis, interpre-
tation and distribution of current process states and his-
torical data from the process database. With the DataMon-
itor, WinCC process data can thus be made available to all 
functional levels in the enterprise via the Web.

Powerful tools for the depiction and interpretation of cur-
rent process states and historical data (measured values, 
messages, user data) from the process database enable 
the production to be efficiently monitored and analyzed as 
well as reports to be created and distributed to the appro-
priate persons. For the display, a DataMonitor client can 
be set up on any office PC. The data provider – a WinCC/
Web Navigator server or a WinCC/DataMonitor server– is 
installable on any WinCC single-user system, WinCC server 
or WinCC client.

WinCC/DataMonitor

Description

Design and functions 

Benefits

• Displaying and analyzing current process status condi-
tions and historical data on office PCs using standard 
tools like Microsoft‘s Internet Explorer or Microsoft Excel 

• No additional time and effort for configuration, since 
you can directly use pictures from the WinCC project

• Evaluation via centrally administrated templates for 
detailed analyses of company processes (e.g. reports, 
statistics) 

• Creating event- or time-controlled reports  
• Information from the process can be grouped on an  

individual basis at runtime (information portal) and 
distributed to different people by e-mail 

• User administration with user groups and individual  
access rights (read, write, create of WebCenter pages) 

The DataMonitor and its tools

For visualization and analyzing the WinCC/DataMonitor 
comprises several internet capable tools that support all 
common security features like Login/Password, firewalls 
and encrypting procedures.

• Process ScreensPurely for monitoring purposes of 
WinCC process screens  

• Trends & AlarmsDisplay and analysis of archived process 
values and alarms in trends or tabular form 

• Excel WorkbooksDisplay of archived process values in  
an Excel table for the analysis and storage on the Web 
or as print template for reports 

• Published ReportsGeneration of time-controlled or 
event-controlled reports in Excel format or as Portable 
Data File (PDF) 

• WebCenterCentral information portal for the access  
to WinCC data via user-specific views, clearly arranged 
Web-Center pages due to user-groups with individual 
rights for reading, writing or creating web-center pages.



Design and functions 

Process screens

The function Process Screens is used purely for monitor-
ing purposes and for the navigation across WinCC process 
screens with the MS Internet Explorer as a so-called 
“viewonly client” with an adjustable cursor. In doing so, 
the WinCC/DataMonitor employs the same mechanisms  
as the WinCC/Web Navigator, e.g. for the communication, 
the user administration, the display of screens.

Trends and Alarms

Trends and Alarms is a tool for displaying and analyzing 
archived WinCC process values and alarms. A predefined 
page already contains the displays for the process value 
table, the corresponding trends, the alarm table and the 
alarm hit list with the associated operator functions. Also 
included are the statistics functions from WinCC for pro-
cess value patterns and alarms (e.g. average, standard 
deviation, variance). Tables only have to be linked with 
the desired WinCC archive data (measured values or 
alarms). Chosen data can also be exported to a CSV  
file and be processed further at a later time (e.g. 
compression).

Excel Workbooks

The Excel Workbooks are a reporting tool for the display 
of alarms and current or archived process values in an 
Excel table. The data can then be analyzed via Excel func-
tions and also be graphically formatted and summarized 
in a report. Once Excel workbooks have been created, 
they can be published and made available to the Intranet/
Internet, or be used as templates for reports to be auto-
matically generated.Reports can also be generated offline 
and stored locally as a customer specific analysis.

Published Reports

Published Reports automatically generate print jobs from 
WinCC reports and prepared Excel workbooks. The reports 
are started time-controlled (e.g. at the end of a shift) or 
event-controlled (e.g. upon the change of a WinCC tag) 
and can be distributed by e-mail. Reports created by Excel 
are saved as XLS file. The corresponding file created by 
the WinCC Report Designer is stored in PDF format. and 
can be further processed and analyzed afterwards.

Fig.: Excel Workbooks



Design and functions 

WebCenter

The WebCenter is the central information portal for the 
access to WinCC data via the Intranet or Internet.

Here, users with corresponding user rights can compile 
WinCC process data, alarms and process screens for any 
number of screen views for various groups of persons.  
By means of these views, WinCC data can be compared, 
analyzed, interpreted and if necessary also exported over 
absolute or relative time periods. When analyzing histori-
cal data, the connection or disconnection of swapped 
archives is possible via commands.

Selectable licensing

The licensing takes place sever-based, i.e. is made at the 
Web Navigator server or DataMonitor server. Depending 
on the selected license, the DataMonitor software pack-
age for the DataMonitor server contains up to 50 client 
licenses. The number of client licenses denotes the maxi-
mum number of clients that can be active at the same 
time, whereas in principle, any number of clients can be 
connected. For upgrading the number of simultaneously 
active clients, Powerpacks are offered.

In a WebCenter page, the user can configure and save 
own screen views made from WebParts. WebParts are  
process value tables, trends, statistics displays, timesteps 
(for the clear depiction of precompressed values), and 
alarm tables (incl. hit list), as well as a display for graph-
ics, links, and favorites. WinCC process screens can be 
integrated into the WebCenter without installation work 
using the WebPart Process Screens.

This allows various information from the plant to be  
generated in an understandable form for different user 
groups, corresponding to the function areas of a com-
pany, e.g for Quality Assurance (e.g. tables and trend  
diagrams with operating figures), the plant operator  
(e.g. pie charts with piece counters) or the service per-
sonnel (e.g. trends with temperature characteristics).



Flow of information between  
production (WinCC) and the IT world

WinCC/IndustrialDataBridge uses standard interfaces to 
link the automation level (controls) to the IT world and to 
ensure a flow of information in both directions.

Systems from different manufacturers can be integrated 
by using a variety of standard interfaces (e.g., OPC, OLE-
DB, SQL). The easy configuration (without programming) 
saves time and prevents errors. The integration into the 
WinCC system and its user administration as well as the 
alternative use as system service guarantee the security  
of the transmission.

WinCC/IndustrialDataBridge

Description Benefits Design and functions 

• Connection of WinCC to databases and IT systems
• Support of standard interfaces (such as OPC, SQL, ODBC, 

OLE-DB, Office formats) means there is no restriction to 
specific vendors

• High-performance, bidirectional data exchange between 
different systems

• Runtime administration of data connections in WinCC 
(also via Web) or via independant application running  
as system service 

• Visualization of information on HTML-pages
• Fast and reliable due to configuration instead  

of programming (errors are prevented)

IndustrialDataBridge exchanges data between automation 
systems from different manufacturers.

• Coupling of SCADA and control systems from different 
manufacturers by means of the OPC interface

• Central information hub for parallel access to one or 
more WinCC systems

• Cyclic data archiving can be implemented via the OPC 
Data Access, WinAC ODK or Send/Receive data sources 
and the SQL database data target

 Video WinCC/IndustrialDataBridge

https://www.youtube.com/watch?v=fdVc-EElXuI


Provider (data sources) Consumer (data destinations)
csv, txt
MS Excel 2003, 2007, 2010, 2013

MS Access 2003, 2007, 2010, 2013 MS Access 2003, 2007, 2010, 2013
MS SQL Server 2005, 2008, 2008R2, 2012 MS SQL Server 2005, 2008, 2008R2, 2012
My SQL 3.5, 5.1, 5.5, 5.6 My SQL 3.5, 5.1, 5.5, 5.6
Oracle 8i, 10g, 11g, 12c release 2 Oracle 8i, 10g, 11g, 12c release 2
OPC Data Access 3.0 
OPC XML 1.0 OPC Data Access 3.0 
OPC XML 1.0 

IDB OPC Server
Send/Receive Send/Receive
WinCC V7.2, V7.3 (via OLE DB) 
WinCC UserArchives V7.2, V7.3 WinCC UserArchives V7.2, V7.3 
WinCC RT Professional V13 SP1 (via OLE DB) WinCC RT Professional V13 SP1 (via OLE DB)

Configurable TXT/ HTML

Description

Data sources and destinations inside IndustrialDataBridge

Online
Data Exchange

Online
Data Exchange

Online
Data Exchange

Online
Data Storage

SIMATIC WinCC - IndustrialDataBridge

Microsoft SQL Server
Microsoft Access

Oracle
My SQL Server

Microsoft Excel
File (CSV)
Free Text
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SIMATIC NET OPC Server
OPC DA & OPC XML DA

SIMATIC WinCC
User Archive WinCC RT Professional

Microsoft SQL Server
WinCC OLE-DB database

(Alarm, Tag Logging)
Send & Receive



Design and functions 

Start as system service for unmanned servers in computer 
centers or IDB integrated in WinCC user interface incl. run-
time administration of connections.

Flexible switching between applications

Application scenarios:

• Reading/writing of WinCC data from/to Office formats 
such as MS Excel or MS Access

• Reading/writing of WinCC data from/to databases
• With a database as a data source, central recipes can be 

transferred directly into WinCC UserArchive or a control-
ler, for example

• Event-driven reports, e.g., automatic shift report in 
CSV files at end of shift (relevant messages and process 
values per shift). The name of the file can be assigned 
as required.ext 

IndustrialDataBridge makes a connection between the 
source and destination interface and transfers the data as 
follows

• depending on a change in value 
• after a configurable time has expired   
• or if a specific event occurs
• Individual data or data blocks (>,<,inside where…)  

are transferred 

The data exchange can be bidirectional via up to 32 data 
connections. Depending on the volume of data, licenses 
are available with 128, 512, 2k and 10k tags.



 Video “SIMATIC Information Server“

The SIMATIC Information Server gives you transparent 
access to plant information at any time. Historical plant 
data can be simply compiled in web-based dashboards or 
reports without programming knowledge. This ensures 
comprehensive access to plant information for each target 
group in the company (managers, quality assurance, 
maintenance) at all time.

SIMATIC Information Server

Description Benefits

• Full transparency of historical WinCC data  
(WinCC Archive and SIMATIC Process Historian)

• Uniform and independent of version for different  
data sources

• Efficient, web-based analysis through clearly structured 
dashboards and automated reports

• Process information can be compiled online during 
runtime

• Quick generation of standard reports through prepared 
templates

• Individual reports based on the Microsoft Reporting 
Services

• Cyclic activation of reports based on demands or  
events and forwarded by email, if necessary

• Simple analysis with MS Office through integration  
in MS Word, MS Excel or MS PowerPoint

• Plant information at any time – from any location:  
Web-based analyses also on mobile devices

https://www.youtube.com/watch?v=2uM6hRkAnC0&feature=youtu.be


Design and functions 

The integrated reporting system, based on the Microsoft 
SQL Server Reporting Services, creates and manages dash-
boards and reports interactively and makes them available 
on the web at any time. Integration in Microsoft Word, 
Excel or PowerPoint also lets you access historical data 
using the tools you know from the Office environment.

By making the SIMATIC Information Server available for a 
variety of products, it can be used for any WinCC system 
even across different versions. The SIMATIC Information 
Server is also used as a reporting system for the SIMATIC 
Process Historian.

Licenses 

• The SIMATIC Information Server basic license gives  
access to one data source for up to three clients

• The number of simultaneous client access operations 
can be incremented at any time using Information 
Server client access licenses

• Additional data sources can be integrated at any time 
using additive data source licenses

Existing knowledge can be optimally reused thanks to the 
integrated analysis of data from different sources with 
only only reporting tool. Comprehensive analyses with a 
uniform look and feel create transparency and show weak 
points. Necessary optimization measures can be devel-
oped quickly and efficiently to increase plant productivity 
and availability. 

The SIMATIC Information Server is installed on a separate 
PC or on a WinCC single-user station, WinCC server or 
WinCC client.



Would you like to considerably expand the functionality of 
WinCC for a sector-specific application? Do you want to 
integrate your own data in WinCC tools, e.g. the reporting 
and logging system?
The WinCC options package Open Development Kit WinCC/
ODK specifies open programming interfaces, which you 
can use to gain access to data and functions of the WinCC 
configuration and runtime system. The interfaces are 
designed as C-Application Programming Interface (C-API). 
Programming examples show the use of C# and VB.NET 
with WinCC /ODK.
Starting with  WinCC V7.2  the former option WinCC/Indus-
trialX is part of the Open Development Kit.
WinCC/IndustrialX is an option that further simplifies the 
solving of a visualization task by standardization of user-
specific objects. No separate display object is required  
any more for each motor, pump, valve, etc., instead 
objects of the same type are standardized. Engineering 
become more cost-efficient, if functions and displays can 
be used repeatedly.

WinCC/ODK (Open Development Kit)

Description Benefits Design and functions
• Individual system expansions via an open standard 

programming language (C++, C#, VB.NET)
• Access to data and functions of the WinCC configura-

tion and runtime system  
• Development of your own applications and add-ons  

for the WinCC basic system
• Easy creation using configuration wizards
• Fast-track starting due to the use of standards:  

ActiveX technology, creation using Visual Basic
• Central creation and modification of object represen-

tations of the same type (type-coding) saves you time 
and money

• Configuration of intelligent, vertical market and 
technology-specific objects (graphic representation  
and logical processing) with expertise protection

• Can be used on a diverse basis: in WinCC pictures and 
other Windows applications (e.g. Internet Explorer, 
Excel)

For example, ODK functions can be used 

• to generate a message  
• to determine the value of a tag  
• to change the object properties in a screen 
• to export a database table 

IndustrialX employs the ActiveX technology for the  
process visualization. Configuration wizards make the 
creation of your own standard displays easy. IndustrialX 
controls are flexible and can be tailored to meet the 
requirements of the most varied applications, for example 
specific for applications in the chemical, glass or paper 
manufacturing industries. IndustrialX offers code tem-
plates for easy linking customerspecific ActiveX controls 
to WinCC data sources that are themselves suitable for 
use on Web Navigator clients.

Including former option  
WinCC/IndustrialX



Quick and easy to configure 

Using the IndustrialX Control Designer, you create one 
IndustrialX control for process objects of the same type, 
e.g. for several motors. Linking is carried out of the indi-
vidual data of a data record e.g. the target value, actual 
value, temperature and operating mode. Once you have 
created the IndustrialX control, you can integrate it into 
pictures as often as you like. 

Design and functions
At integration, you only need to specify the name of the 
data record. At runtime, each integration of the Industri-
alX Control then automatically works with the data of the 
assigned data record. Each time the IndustrialX Control is 
used, you do not need to spend time and effort on linking 
the individual data.

Carry out modifications on a central basis

If you have a lot of IndustrialX Controls, which are already 
integrated in process pictures, you can easily change them 
later. Such changes are made once at a central location 
and can affect the graphic representation as well as the 
processing logic. All the changes affect all the IndustrialX 
controls in all the process pictures that have already been 
configured. If, for example, there are 47 motors of the 
same type in a plant that are visualized in 13 different  
process pictures using IndustrialX controls, you only need 
to make the changes once at a central location.  
These changes are then effective everywhere. This obvi-
ates the need to carry out time-consuming, errorprone 
changes at 47 different locations!

Rapid processing, know-how protected

IndustrialX controls are composed of compiled Visual 
Basic code that guarantees fast, effective processing.  
The technological know-how that you invested in creating 
your controls can - if necessary - be protected from copy-
ing if the source code is not supplied.

In the delivery kit for WinCC/ODK there is a CD-ROM with 
several examples and a voucher for a one-day training  
session and expanded support via a telephone hotline.

ODK functions are also employed by the WinCC Compe-
tence Centers and WinCC Specialists for the development 
of technology and industry-specific WinCC Add-Ons.



With the WinCC/PerformanceMonitor, plant-specific  
key figures for individual devices, machines, or entire  
production lines can be calculated and analyzed in 
machine or line-oriented production plants. 
• OEE  – Overall Equipment Efficiency
• MTBF – Mean Time Between Failures
• MRT – Mean Repair Time
• and further Key Performance Indicators (KPI)
The production equipment can be defined individually 
depending on the specific plant.
The option WinCC/Downtime Monitor which was used in a 
comparable area of application will no longer be released 
for WinCC V7.2 and higher.

WinCC/PerformanceMonitor

Description Area of application

Management and quality assurance 

• Complete transparency for all machines as basis for 
optimizing the plant’s productivity:

• Logging of downtimes, localization of causes and 
reasons for downtimes, and monitoring of equipment 
efficiency

• Basis for decision making based on performance  
indicators

• Reports of the InformationServer available worldwide 
and target-group-oriented for each user

• Identification of production interrelationships by  
combining key figures with associated values such  
as material used

Maintenance and repair 

• Minimum training period and simple configuration  
due to the integration into the SCADA System

• Standardization of new systems by defining control-
based status information to calculate key figures

• Individual, targeted analysis through plant-specific  
key figures via Intra- or Internet

• Adding additional plant performance indicators out of 
existing process data during the on-going operation

• Weak point analysis in production processes and detec-
tion of undesirable process behavior

• Cause analysis through examination of the basis for 
calculation “drilldown to operands”

• Identification of events that lead to cost-intensive 
failures 

Line management and system operators 

• Analysis of performance indicators can be displayed as 
table, Performance- or Gantt chart also in the WinCC/
WebNavigator

• Subsequent correction of archived input values
• Continuous information at the operator interface 

through integration in the WinCC user interface
• Flexible calculation of the performance indicators using 

different time frames (cyclic, interval or event-driven)
• Quick identification of weak points in the process 

through cyclical key figure calculation

Production analysis and optimization on the 
basis of individual key performance indicators

 Video “SIMATIC WinCC/PerformanceMonitor“

https://www.youtube.com/watch?v=hbfZ4Jbnq28&feature=youtu.be


Using the WinCCPerformanceMonitor makes it possible  
to show the weak points of the production and to derive 
suitable optimization potential. 
• Flexible – Individual calculation of plant specific perfor-

mance indicators within SIMATIC WinCC
• Reaching the goal quickly – because of the integration 

in WinCC short configuration- and training period
• Setting up correlations - recognizing performance  

indicators within the content e.g. quality per vendor
• Being optimally informed – Analysing of the perfor-

mance indicators and displaying them as bar- or Gantt 
– diagram or as a table also using the Web

• Viewing everything at any time – Target–group oriented 
analysis reports using the SIMATIC Information Server

• Extendable – Adding of performance indicators within 
existing plants without any loss of production

Benefits Design and functions

Fault analyses provide information about the frequency 
and duration of machine or plant downtimes.  
Corresponding display instruments can be effortlessly 
integrated in WinCC process pictures. 

The determined data gives information on the effective-
ness of individual machines and of entire production 
plants.The transparency of the data allows for a quick 
response and countermeasures in the event of faults, 
which increases the availability of the machine.

• Structuring of the production plant into individual 
equipment units as central components for evaluations 
(equipment efficiency)

• Applicable for single machines as well as for complete 
plants

• Simple integration into existing plants which are  
controlled by WinCC

• Calculation of the operands via freely definable  
formulas from preconfigured WinCC tags

• Cyclical or event-driven calculation of key figures  
based on archived operands

• Combination of key figures for associated values,  
e.g. material used, produces production contexts

• If needed, key figures can be written to WinCC tags  
(for example, trend display of the key value) 

All of the analysis results are integrated in the form of  
controls in WinCC screens. Performance- Gantt- and table 
views are available in WinCC- process pictures but also 
using the WinCC/WebNavigator. A distinction is made 
between several different display instruments:

• Bar chart for analysis of key figures and their associated 
values.

• Determination of causes (drilldown) by displaying  
the input values (operands)

• Tabular display of all operands (input values)
• Gantt chart for time-based operands



Design and functions
Web-based, user-specific reports with the  
SIMATIC Information Server

• Optimizing of the overall plant productivity based on 
the full transparency of the machinery

• Recognizing the production-oriented contexts by 
combining of performance indicators with associated 
values, e.g. used materials

• Calculation of downtimes and recognizing their reasons
• Analysis of weak points within production processes

The basic package consists of the configuration environ-
ment, the runtime controls (bars, Gantt chart, table) and 
the license to archive 30 values. The archived values 
(operands, context) form the basis for the analysis. 

If more values must be archived they can be increased in 
steps of 30, 100, 300 or 1000 archive values (additive).

If you now optimize your plant you can benefit from the 
WinCC Analyze and Starter Package which is available up 
to the 09/30/2015. This package consists of the base 
packages of the WinCC/PerformanceMonitor V7.3 and  
the SIMATIC Information Server 2014.

 Fig.: Web-based report with SIMATIC Information Server



Increased productivity is being achieved more and more 
by cutting costs. In this context, the focus is increasingly 
on maintenance. The emphasis here is on rectifying faults 
as quickly and efficiently as possible. Ideally, the operating 
personnel should also perform part of the maintenance 
tasks. The operating personnel are on-site, they are famil-
iar with the procedures and can intervene quickly. This 
saves time and reduces costs. It is precisely here that Pro-
Agent can assist operating personnel in identifying faults 
quickly, particularly in the automotive and machine tool 
industries.

In the event of a process fault, process error diagnostics 
with SIMATIC ProAgent will provide information about  
the location and cause of that fault and support personnel 
with troubleshooting. The ProAgent solution has been 
optimized specifically for use with SIMATIC S7-300/S7-400 
and SIMATIC WinAC. It can be used in combination with 
the S7-PDIAG, S7-GRAPH STEP 7 engineering tools. The 
ProAgent option package features standard displays that 
are updated with process-specific data during runtime.

WinCC/ProAgent

Description Benefits Design and functions
• Component of Totally Integrated Automation:  

Increases productivity, minimizes engineering outlay, 
reduces lifecycle costs 

• Support for troubleshooting, increased machine and 
plant availability, shorter downtimes 

• No additional configuration costs for the diagnostics 
functionality due to automatic generation of the diag-
nostics- related parts for the controller and HMI 

• Frees up controller capacity with regard to memory 
requirements and program execution time 

• No special knowledge required to operate

Increased availability due  
to process diagnostics
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Standard views instead of configuration 

ProAgent is available for various devices and software 
platforms from the SIMATIC HMI range: Panels and Multi 
Panels, WinCC flexible and WinCC. ProAgent contains stan-
dard views, which are attuned to the requirements of the 
process error diagnosis of a plant or machine. During con-
figuration, the data that is relevant to process error diag-
nostics such as symbols, comments and alarm texts are 
saved in a standardized data management system. During 
runtime, the standard screens are then filled with process-
specific data.
For SIMATIC WinCC, ProAgent directly accesses the engi-
neering data and imports it into the WinCC project. The 
ProAgent standard screens needed for the diagnostics 
mode are automatically created in WinCC. ProAgent and 
STEP 7 engineering tools represent a standardized diag-
nostics concept for SIMATIC S7. No additional configura-
tion overhead for the WinCC application is thus required 
for the diagnostics functionality. The standard views are: 
alarm view, unit overview, diagnostics detailed view, 
motion view and the sequencer operating display.

Design and functions
Functional scope 

• Context-sensitive diagnostics initiation due to process 
error message 

• Output of the operands with symbols and comment 
Switch-over capability between LAD, STL and signal list

• Supporting fault rectification by means of direct process 
access when using the motion view 

• Output of the faulty operands directly in the alarm 
including address, symbol and comment 

• Consistency test in runtime: Inconsistent diagnostics 
units are marked with icons. This permits quick locating 
of faults regarding configured data in the commission-
ing phase

• Direct, unit-related entry point in the diagnostics view 
from user displays (by using ProAgent functions) 

• Unit or alarm-related entry to STEP 7, e.g. LAD/STL/FBD 
editor, S7-GRAPH, HW CONFIG upon system error mes-
sages, is supported fully automatically 

• S7-GRAPH OCX for the graphical display of step  
sequences (overview display) 

G
_S

T8
0_

XX
_0

05
81

STEP 7

 Fig.: WinCC/ProAgent: process error diagnostics



The SIMATIC Process Historian is a real-time database for a 
variety of products and versions that serves as central data 
interface to the company management level. It serves as 
central long-term archive for any amount of process data 
and messages from different data sources. 

SIMATIC Process Historian

Description
• Central interface to the corporate management level
• Real-time archive for any amount of production and 

MES data for the entire plant
• Version independence of the data sources
• “One-click” configuration for easily scalable data volume
• Maximum access speed using minimal memory through 

intelligent compression algorithms
• Security through redundancy, disaster recovery and 

Store & Forward mechanisms
• Openness through OPC UA server
• Full transparency of Historian data with the SIMATIC 

Information Server

Benefits

Archiving in a high-performance SQL database in com-
bination with efficient data compression mechanisms 
ensures that critical data will be available at any time 
in the future while using very little memory.

Central archiving of company data facilitates fast  
decision making on the basis of secured data. Full 
transparency is ensured by the SIMATIC Information 
Server.

SIMATIC Process Historian replaces the previous 
WinCC/CentralArchiveServer option.



The SIMATIC Process Historian is scalable and collects and 
archives any amount of data, independent of version, 
from different systems. SIMATIC Process Historian, which 

is scalable thanks to its seamless integration in WinCC, 
including redundant configurations, meets the strictest 
security requirements with minimal administration.

Security

Data security is essential when using a Historian. The 
SIMATIC Process Historian offers a series of security mech-
anisms and therefore ensures that plant data can be reli-
ably archived. Any potential failures are usually prevented 
by using a redundant Historian in combination with the 
installation of RAID systems. Loss of data due to problems 
in the network connection between the plant and Histo-
rian is prevented by using the “Store & Forward” mecha-
nism. If a complete system breakdown nevertheless 
occurred, the database can be completely recovered 
through backup (disaster recovery).

Openness

SIMATIC Process Historian offers an OPC UA Server  
interface for connection to any IT or MES system.

Licenses 

• The SIMATIC Process Historian supports the archiving  
of any amount of data 

• The archive data is licensed at the data source,  
for example, in WinCC systems

• The redundancy package is required for the redundant 
Process Historian

• The OPC UA interface needs a separate license

Design and functions

 Video “SIMATIC Process Historian“

https://www.youtube.com/watch?v=hbfZ4Jbnq28&feature=youtu.be


Increasing system availability due to redundancy in the 
case of applications with WinCC is possible by using
• redundant servers,  
• redundant communications paths  
• and highly available controllers.
The WinCC/Redundancy option gives the user the opportu-
nity to operate two linked WinCC single-user systems or 
server PCs in parallel, in order to monitor each other.  
For both redundancy partner servers you need one of the 
two redundancy licenses that are supplied with the option 
package. On the failure of one of the servers, the second 
server assumes control of the entire system. When the 
failed server resumes operation, the contents of all mes-
sage and process value archives are copied back to the 
restored server. All in all, this results in significantly higher 
levels of system availability.

• Increased system availability with continuous data 
integrity 

• Automatic switching in the case of a server failure or 
communications failure with the server 

• Continuous operation and visualization due to automat-
ic switching of the clients to the intact server 

• Automatic matching of all the archives, alarm infor-
mation and internal variables in the background after 
eliminating the disturbance

In a normal situation, two WinCC stations or process data 
servers operate completely in parallel, i.e. each station has 
its own process connection and its own data archives.
If either of the WinCC stations fails, the other one takes 
over archiving of messages, process and user data. This 
guarantees constant data integrity. In clientserver opera-
tion, the system automatically switches clients from the 
failed server to the redundant machine. This guarantees 
continuous visualization and operation of the plant at 
each operator station. When the failed server starts up 
again, the system automatically matches in the back-
ground all the process values, messages (incl. statuses, 
acknowledgements, lists and comments) and data from 
the user archive for the down period (without influencing 
online operation) – this means that two stations are avail-
able again that have the same data. 

WinCC/Redundancy

Description

Benefits

Design and functions

Increasing system availability

WinCC
Server

WinCC
Clients
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Additional increase in system availability

In addition to using the WinCC/Redundancy option for run-
ning two servers in parallel, it is possible in a WinCC appli-
cation to also implement redundant communication chan-
nels to the SIMATIC S7 controller. You do this by installing 
two communication modules and implementing duplicate 
communication paths (communication software S7-RED-
CONNECT needed). By using H-series SIMATIC S7 control-
lers, you can, if required, additionally increase availability 
at the control level. By combining system solutions, you 
can create a security concept that meets even the most 
demanding requirements.



A multi-user system is used whenever the same process  
is to be monitored at several operator stations. When the 
Option is used, several operator control and monitoring 
stations are coordinated to operate together with net-
worked automation systems. The server supplies the con-
nected clients with process and archive data, messages, 
pictures and logs. The result of an operator action at one 
operator station, for example, changing a value or mes-
sage acknowledgment, is immediately available to all 
other operator stations.

Integrated scalability from the single-user system to the 
client/server solution Economic solution for SCADA appli-
cations with higher complexity Configuration of distrib-
uted operator stations with little effort Configuration of 
distributed client/server systems with up to 18 WinCC 
servers. Clients provide access to all servers in the system 
Configuration of clients as remote Web servers Low-cost 
configuration on the client.

The server establishes the connection to the automation 
system, handles the communication and coordination of 
the clients, and performs all archiving in the integrated 
Microsoft SQL database. WinCC clients access the configu-
ration data of the server directly. Access rights are used  
to define the functions or plant sections that are available 
to a user on an operator station. The configured authori-
zations are user-related, not computer-related. They 
therefore work with all operator stations with the same 
login.

Licenses

The following licenses are required for configuring  
a multi-user system:
• WinCC Server license on the server in addition  

to a WinCC RT license
• One WinCC Client license on each client

WinCC/Server

Description Design and functions

Benefits

Setup of client/server systems

WinCC Server

WinCC Clients
(max.32)
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 Fig.: Simple client/server configuration





WinCC/SES (Sequence Execution System) is a WinCC 
option designed for the sequence control of recipe- and 
sequence based processes like mixing processes in the 
food and beverage production. Using predefined visuali-
zation templates and function blocks a very high level of 
engineering efficiency can be achieved. That’s why plant 
designers as well as plant engineers can save as well  
engineering time as also test- and commissioning time.

WinCC/SES

Description

Layoutdaten

Scalable SCADA functionality  
for sequence based processes

WinCC/SES is designed to use in manufacturing facilities 
where dosing, mixing as well as material handling is very 
important. In such plants the raw materials which are 
stored in tanks, silos or vessels have to be combined in 
the right order with reactors and processing machines. – 
This has to work with several processing steps up to the 
final product. The plant operator has to define the produc-
tion steps within his production unit. He also has to set 
the production parameters like the set points and he has 
to define the production flow using sequences.

Area of application

A high system availability and fast reaction time are typi-
cal for the WinCC/SES module because of the fact that the 
sequences are processed on the PLC and not on the PC.
That is the reason why on one hand real-time behavior is 
achieved because of the much faster cycle time of the 
PLCs. On the other hand it also increases the failure-safety 
because if the batch has started it is still processed even if 
the PC crashes. After production start the SES control dis-
plays all steps and production parameters like set points 
and actual values as well as the actual state of the produc-
tion step in a very clear and transparent manner. Due to 
that fact for an operator it is possible to adjust production 
processes very fast during normal operation for example 
by changing the sequence of the steps manually. This for 
example can be necessary if the quality of the natural 
resources varies or if it is necessary to change the order  
of the steps to reach flexible paths through the produc-
tion process.

Design and function

Benefits

• Minimized engineering effort because of  
standardization

• Quality intensification due to efficient  operational 
management

• Flexible production paths are possible leading to  
a consistent load within the production processes  

• Fine adjustment of the production processes while  
the behavior of the natural resources drift

• Real-time behavior because the single steps are  
processed in the PLC

• High availability
• Low training- and operational costs 



SIMATIC WinCC/TeleControl flexibly integrates remote  
terminal units into the central process visualization system 
of the entire plant via a WAN (Wide Area Network).  
SIMATIC WinCC/TeleControl supports the three most 
importantinternational telecontrol protocols IEC 60870-5 
101/104, DNP V3 (serial or TCP/IP), and SINAUT ST7 (serial 
or TCP/IP). The diverse supported network topologies and 
transmission protocols allow a flexible configuration 
according to individual requirements.

WinCC/TeleControl

Description Area of application

Integration of remote terminal units  
in central process visualization

Widely spread plants especially in the industries:

Water/Waste water

• Water wells, pumping stations, Shut-off slides in  
water supply mains and irrigation systems

• Rain overflow basins and lifting stations in sewage 
networks

• Elevated tanks 

Oil and gas industry

• Compressor-, pressure control-, transition- and  
measuring stations in gas networks

• Pumping stations and gate walves in oil pipelines

• Installation, commissioning and maintenance costs  
can be reduced considerably

• Worldwide use and support of international telecontrol 
protocols (SINAUT ST7, IEC 60870, DNP3)

• Flexible configurations to match individual requirements
• High availability and data security due to redundancy 

concepts
• Cost-efficient due to optimized data transmission
• The uniform user interface for local and remote process-

es minimizes expenditure and the probability of errors
• Remote programming with SIMATIC S7-RTUs

Benefits

The software can be individually adapted to the require-
ments of a plant. The uniform user interface for local and 
remote processes minimizes the risk of errors.  
Less time is required for training of employees because 
the same SIMATIC WinCC process visualization system is 
used for telecontrol and for the actual process 
visualization.



Design and functions

WinCC/TeleControl (for WinCC V7.0 SP2) supports the 
following preferred remote terminal units for distributed 
automation on-site:

• Controller integrated in ET 200S (Modbus,  
IEC 870-5-101/104 telecontrol protocols);  
for cost-sensitiv applications

• Controllers S7-300/S7-300F (SINAUT ST7, DNP3,  
Modbus, IEC 870-5-101/104 telecontrol protocols);  
for extremely flexible configurations

• Redundant controllers S7-400H/S7-400FH 
(IEC 870-5-101/104 and DNP3 telecontrol protocols) 
for higher requirements e.g on data security

• Third party stations with telecontrol protocols Modbus, 
IEC 870-5-101 and IEC 870-5-104 (depending on  
station type)

WinCC/Telecontrol (for WinCC V7.0 SP2) can be  
individually adapted to the requirements of a plant.

• Support of communication media with 
 ー – serial interface, e.g., dedicated lines,  

dial-up connections (analog, ISDN) 
 ー radio transmission devices (standard, spread  

spectrum modulation), microwave and GSM 
 ー TCP/IP based WANs e.g., DSL, GPRS or Ethernet  

wireless networks
• Network topologies – point-to-point, multidrop  

(multi-user mode) and hierarchical network structures
• Cost-efficient due to reduced data volume by using 

event-driven communication mechanisms
 ー Time synchronization of RTUs and correct time  

stamping of data
• Prevention of data losses in case of communication 

failures
• Redundancy for communication connections and  

servers

DNP V3   (seriell oder TCP/IP)
oder
SINAUT   ST7 (seriell oder TCP/IP)

Fremd-RTU 2)

Industrial Ethernet

Industrial Ethernet

WAN

WAN

S7-400 
+ TIM 4R-IE

S7-300 
+ TIM 3V-IE

WinCC Clients

WinCC Server + 
Telecontrol

Modem

WAN RouterTIM 1)

2) Remote Terminal Unit1) Telecontrol Interface Module

S7-400 
+ CP 443

S7-300 
+ CP 343

ET 200S 
+ PN-CPU

IEC 60870-5 101/104
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The WinCC/User Archives option allows the application  
of User Archives, in which related data is stored in data 
records.

WinCC and its automation partners (e.g. a SIMATIC S7 PLC) 
can write to these data records and exchange them 
among one another if required.

WinCC/User Archives

Description Design and functions

Managing data sets

An operator, for example, can enter parameter sets (the 
operating parameters of a machine) in WinCC, store them 
in the user archive and forward them to the automation 
level as needed. On the other hand, an automation sys-
tem can continuously acquire production parameters dur-
ing a shift and send them to WinCC at the end of the shift. 
Further application examples are the acquisition of batch 
data, the specification of production parameters or the 
administration of storage management data.

WinCC user archives are conveniently created in a sepa-
rate editor and preallocated with data. Special ActiveX 
Controls, which are integrated in the object palette of 
WinCC Graphics Designer, are used to display data from 
the user archives during runtime. These controls can also 
run on the WebNavigator in an Internet environment. 
The coupling of data sets and fields from user archives  
to the process is easily done via direct tag connection.

• Storing and managing of any user data in data sets
• Flexible display via WinCC User Archive Control,  

with optional table and form view
• Easy connecting of data set fields to the process  

via direct tag connection
• Import/export functions for further processing  

with other tools (e.g. Microsoft Excel)

Benefits

Fig.: User Archive Editor

Fig.: WinCC/User Archives Runtime Control



The WinCC/Web Navigator allows you to perform operator 
control and monitoring of your plant via the Internet or  
an in-house intranet without the need for changes to  
the WinCC project. In addition to the typical use in WANs 
(Wide Area Networks), low-cost applications can also  
be implemented. Examples of these are solutions in the 
water/wastewater industry with highly decentralized 
structure or applications with sporadic access to process 
information (building management). In addition to this, 
Web clients can also be used as normal operator stations 
on the LAN.

WinCC/Web Navigator

Description

Operator control and monitoring  
via the web

• Parallel web-based operator control and monitoring  
(MS Internet Explorer)

• Integrated configuration and user administration/access 
authorizations

• User-specific functionalities, e.g. language,  
plant (unit) view

• Fast update rates (e.g. after value change,  
picture change)

• Minimum maintenance costs thanks to centralized  
software administration

• High Internet security standards
• Remote monitoring using the secure WinCC Web  

Viewer application
• Flexible thin client solutions for a variety of platforms 

(PC, on-site panel, mobile PDA)
• Efficient remote diagnostics with WebDiagnostics 

server/client
• Increased security and availability due to separation  

of WinCC and Web server
• Maximum availability and performance thanks to  

Web server farms (load balancing)

Benefits

For WinCC single-user systems or WinCC server/client  
systems, web-based solutions can be implemented with 
the WebNavigator. Operator control and monitoring of  
a WinCC project via the Internet or an intranet is possible 
from any Windows computers, which are referred to as 
WebNavigator clients.Only MS Internet Explorer is 
required on the client side. Simultaneous access to multi-
ple Web servers and thus to multiple plants is even possi-
ble if this is started multiple times or its multi-tabbing 
functionality is used.

Design and functions



Security concept made to order

All Web operator stations are integrated into the user 
administration of the system. Authorization levels govern 
whether an operator can simply monitor the plant (view 
only) or has partial or full authorization for operator con-
trol and monitoring. Every login and logout can be traced 
via system events. For applications with very strict security 
requirements, logout after a user-defined time span is just 
as important as the ability to disable key combinations 
when it comes to security. Furthermore, the WebNaviga-
tor supports all commonly used IT security mechanisms 
such as routers, firewalls, proxy servers, SSL encryption 
and VPN technologies.

Fig.: WebNavigator Client

Thin client solutions

Inexpensive but lower-performance Windows PCs, rugged 
on-site devices (e.g. SIMATIC Thin Clients) and mobile cli-
ents (PDA – Personal Digital Assistant) can be connected 
via thin client solutions with Microsoft Terminal Services. 
Only minimum requirements are placed on the hardware 
here because the entire application, i.e. including the 
WebNavigator client, runs on the terminal server.

Siemens offers rugged SIMATIC Industrial Thin Clients  
as operator terminals with high-resolution wide screen 
touch displays. These are optimally suited for use in harsh 
industrial environments.



Flexible remote diagnostics

The WebDiagnostics client was designed for maintenance 
and service of widely distributed plants. In this case, the 
Web licensing is made for a diagnostic client locally on  
a service computer instead of on the system servers. 
Through the diagnostic client, the service technician has 
secure access to any number of plants that have a Web-
Navigator server.

Dedicated Web server and Web server farms  
with load balancing 

The WinCC Web Server can also be configured on a WinCC 
(SCADA) client for even more security and availability.  
 
Advantages of this solution:
• Increased security and availability due to separation  

of the system server and Web server
• Comprehensive Web solutions for multiple or redundant 

WinCC servers
• Web server farms allow the number of Web clients to  

be increased as needed 
Higher performance through load balancing

• Automatic switchover of the Web clients in the event  
a server fails

Licenses 

• A (server-based) license is required for the WebNaviga-
tor. This is a graduated license based on the number of 
simultaneous Web client accesses, which can be incre-
mented at any time using additive Web client licenses

• The WebNavigator client software can be installed as 
many times as required without the need for a license

• A (client-based) license is required for the WebNavigator 
diagnostics. This provides access to all Web servers with 
WebNavigator server WebNavigator diagnostic server 
license

• Dedicated Web server on a WinCC client with full-fea-
tured WinCC RT 128 license

• Web server in a “Web server farm” on a WinCC client also 
with full-featured WinCC RT 128 and additional load 
balancing license

n WinCC
Web Server

WinCC
Server

n x 150 WinCC
Web Clients
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WinCC/WebUX was developed for use on smartphones, 
tablets, PCs and other mobile devices that support an 
HTML 5 capable browser. No installation on the client  
end is required for using WebUX. 

This flexible access to process and plant data expands  
the control center that is the standard today; it also gives 
users the option to purely monitor or operate depending 
on the area of application. 

Individual access to production data gives users

• fast
• cost-effective
• target-specific
information on all relevant data of a plant.

WinCC/WebUX

Description Benefits

Mobile SCADA over the World Wide Web (www)

• Mobile operator control and monitoring worldwide with all commer-
cially available mobile devices, free selection of devices and browsers

• Worldwide, flexible online access around the clock,  
365 days a year

• Secure communication over HTTPS und SSL certificates
• Integrated user administration with user-specific access authoriza-

tions for monitoring (Monitor client) or operating (Operate client)
• No installation or maintenance of the terminal devices (clients)
• Short time to market because time-consuming additional  

configuration is not necessary
• Consistent look and feel
• No entry costs since a Monitoring client is included in the  

WinCC basic package
• The WinCC server version and version of the mobile clients  

do not have to be the same

 Video “SIMATIC WinCC /WebUX V7.3“

https://www.youtube.com/watch?feature=player_embedded&v=7zt_lYT7_Zw


Design and functions

WinCC/WebUX can be used independent of the industry, 
for example, in Service for acknowledging alarm mes-
sages, in Quality Assurance for monitoring important  
production data, or in Management for viewing key  
production figures whenever required. 

WinCC/WebUX thus meets the constantly growing 
demands by users to monitor processes remotely over  
the Internet or intranet and be able to intervene, if 
necessary.

The WinCC/WebUX option is supplied with the WinCC 
basic system. No additional installation is required on  
the client devices, because the option is a pure browser 
application. 

WinCC/WebUX provides a secure solution for mobile  
operator control and monitoring of the automation  
system independent of device and browser.

The WinCC/WebUX and WinCC/WebNavigator options 
complement one other and can be used at the same time.

Licenses 

• A (server-based) license is required to use the WebNavi-
gator server. This is a graduated license based on the 
number of simultaneous Web access operations and  
can be incremented at any time

• We distinguish between Monitor and Operate clients  
for licensing purposes

• Flexible number of clients thanks to additive licenses 
(floating client)

• The WinCC/WebUX and WinCC/WebNavigator licenses 
can be combined, if necessary

• The WinCC server version and version of the mobile 
clients do not have to be the same

• One free Monitor client in the WinCC system



Single-User-System Standalone Multi-User-System Server*

The system requirements differ 
depending on the type of the 
WinCC installation and the used 
operating system. We strongly 
recommend to use 64 Bit operat-
ing systems. The 32 Bit operating 
systems may be used for compat-
ibility reasons within already 
existing configurations. 

In conjunction with an Embed-
ded SIMATIC IPC system Windows 
Embedded Standard 7 may be 
used when mentioned in the 
requirement tables below.

Operating systems and hardware requirements 
SIMATIC WinCC

Operating systems
Windows 7 Professional/Enterprise/Ultimate SP 1 (32 Bit)
Windows 7 Professional/Enterprise/Ultimate SP 1 (64 Bit)
Windows Embedded Standard 7 SP1 (32 Bit) (only SIMATIC IPC)
Windows Embedded Standard 7 SP1 (64 Bit) (only SIMATIC IPC)
Windows 8.1 Professional/Enterprise (32 Bit)
Windows 8.1 Professional/Enterprise (64 Bit)
Windows 10 (64 BIT)
Windows Server 2008 Standard Edition R2 SP1 (64 Bit)
Windows Server 2012 Standard Edition R2 (64 Bit)
 Recommended Hardware with 32 Bit OS
Processor Intel® Core™ i3 3.5 GHz*
RAM 3 GB
Recommended Hardware with 64 Bit OS
Processor Intel® Core™ i3 3.5 GHz*
RAM 8 GB

* In combination with options, more powerful systems may be required

Operating systems
Windows 7 Professional/Enterprise/Ultimate SP 1 (32 Bit)**
Windows 7 Professional/Enterprise/Ultimate SP 1 (64 Bit)**
Windows 8.1 Professional/Enterprise (32 Bit)**
Windows 8.1 Professional/Enterprise (64 Bit)**
Windows 10 (64 BIT)**
Windows Server 2008 Standard Edition R2 SP1 (64 Bit)
Windows Server 2012 Standard Edition R2 (64 Bit)
 Recommended Hardware with 32 Bit OS
Processor Intel® Core™ i5 2.4 GHz***
RAM 3 GB
Recommended Hardware with 64 Bit OS
Processor Intel® Core™ i5 2.4 GHz***
RAM 8 GB

*       All servers in a multi-user-system have to use the same edition of the  
Operating system. 

**    When using a Workstation operating system a maximum of 3 clients  
can connect to the server

*** In combination with options, more powerful systems may be required



Multi-User-System Client Multi-User-System Client without project

Operating systems
Windows 7 Professional/Enterprise/Ultimate SP 1 (32 Bit)
Windows 7 Professional/Enterprise/Ultimate SP 1 (64 Bit)
Windows 8.1 Professional/Enterprise (32 Bit)
Windows 8.1 Professional/Enterprise (64 Bit)
Windows 10 (64 BIT)
Windows Server 2008 Standard Edition R2 SP1 (64 Bit)
Windows Server 2012 Standard Edition R2 (64 Bit)
 Recommended Hardware with 32 Bit OS
Processor Intel® Core™ i3 3.5 GHz*
RAM 3 GB
Recommended Hardware with 64 Bit OS
Processor Intel® Core™ i3 3.5 GHz*
RAM 8 GB

* In combination with options, more powerful systems may be required

Operating systems
Windows 7 Professional/Enterprise/Ultimate SP 1 (32 Bit)
Windows 7 Professional/Enterprise/Ultimate SP 1 (64 Bit)
Windows Embedded Standard 7 SP1 (32 Bit) (only SIMATIC IPC)
Windows Embedded Standard 7 SP1 (64 Bit) (only SIMATIC IPC)
Windows 8.1 Professional/Enterprise (32 Bit)
Windows 8.1 Professional/Enterprise (64 Bit)
Windows 10 (64 BIT)
Windows Server 2008 Standard Edition R2 SP1 (64 Bit)
Windows Server 2012 Standard Edition R2 (64 Bit)
 Recommended Hardware with 32 Bit OS
Processor Intel® Core™ i3 3.0 GHz*
RAM 3 GB
Recommended Hardware with 64 Bit OS
Processor Intel® Core™ i3 3.0 GHz*
RAM 4 GB

* In combination with options, more powerful systems may be required



System options Web Server System Options Web Client

Operating systems
Windows 7 Professional/Enterprise/Ultimate SP 1 (32 Bit)
Windows 7 Professional/Enterprise/Ultimate SP 1 (64 Bit)
Windows 8.1 Professional/Enterprise (32 Bit)
Windows 8.1 Professional/Enterprise (64 Bit)
Windows 10 (64 BIT)
Windows Server 2008 Standard Edition R2 SP1 (64 Bit)
Windows Server 2012 Standard Edition R2 (64 Bit)
 Recommended Hardware with 32 Bit OS
Processor Intel® Core™ i5 2.4 GHz*
RAM 3 GB
Recommended Hardware with 64 Bit OS
Processor Intel® Core™ i5 2.4 GHz*
RAM 8 GB

* In combination with options, more powerful systems may be required

Operating systems
Windows 7 Professional/Enterprise/Ultimate SP 1 (32 Bit)
Windows 7 Professional/Enterprise/Ultimate SP 1 (64 Bit)
Windows Embedded Standard 7 SP1 (32 Bit) (only SIMATIC IPC)
Windows Embedded Standard 7 SP1 (64 Bit) (only SIMATIC IPC)
Windows 8.1 Professional/Enterprise (32 Bit)
Windows 8.1 Professional/Enterprise (64 Bit)
Windows 10 (64 BIT)
Windows Server 2008 Standard Edition R2 SP1 (64 Bit)
Windows Server 2012 Standard Edition R2 (64 Bit)
 Recommended Hardware with 32 Bit OS
Processor Intel® Dual Core™

AMD Athlon 64*
RAM 3 GB
Recommended Hardware with 64 Bit OS
Processor Intel® Dual Core™

AMD Athlon 64*
RAM 4 GB

In combination with options, more powerful systems may be required



Central Archive Server 
based on SIMATIC Process 
Historian 

Virtualization

Operating system

Windows Server 2012 R2 (64-Bit)

Hardware requirements

Depending on the requirements con- 
cerning quantity frameworks the recom-
mended hardware configuration for a  
central archive solution based on SIMATIC 
Information Server differs. 

We have listed three example configura-
tions (small, medium and large quantity 
frameworks) in the system manual for  
the administration of SIMATIC Process 
Historian. 

• System Manual

The following virtualization systems have 
been tested

•  Microsoft Hyper-V 2012 R2

• VM Ware ESXi 5.5

Prerequisite 

The performance of the virtual machine 
has to meet the requirements of a WinCC 
client system. 

 More information

https://support.industry.siemens.com/cs/document/68099510?dti=0&lc=en-WW


SIMATIC 
WinCC – 
take a look!

Learn everything about 
SIMATIC WinCC

Find out more: 
siemens.com/wincc-V7

Follow us on: 
twitter.com/siemensindustry 
youtube.com/siemens
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Siemens AG 2016 
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Subject to changes and errors.  
The information given in this document 
only contains general descriptions and/or 
performance features which may not al-
ways specifically reflect those described, 
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products. The requested performance  
features are binding only when they are  
expressly agreed upon in the concluded 
contract.
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